WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#16037 closed defect (bug) (worksforme)

include wp-load.php && POST = redirect to /wp-admin/install.php

Reported by: Bjorn Padding Owned by:
Milestone: Priority: normal
Severity: major Version: 3.0.3
Component: External Libraries Keywords: reporter-feedback
Focuses: Cc:

Description

When including wp-load.php in an external php-script and POSTing to that script with (for instance) a browser, redirects the browser to /wp-admin/install.php, instead of the external script getting the chance to process the POST request itself. GETing the script, functions as expected and is processed by the external script.

Change History (5)

comment:1 Bjorn Padding4 years ago

  • Summary changed from include wp-load.php && POST = unexpected result to include wp-load.php && POST = redirect to /wp-admin/install.php

comment:2 SergeyBiryukov4 years ago

  • Keywords reporter-feedback added; POST wp-load.php wp-admin/install.php removed

Can't reproduce neither on 3.0.3 nor on 3.1-RC1-17163.

Might be related to the specific request and/or script.

comment:3 filosofo4 years ago

Maybe it's for multisite? See #14913 as possibly related.

comment:4 SergeyBiryukov4 years ago

I've tried a basic form sample:

<?php 
/* Short and sweet */
define('WP_USE_THEMES', false);
require('./wp-blog-header.php');

if ( !empty($_POST) )
	print_r($_POST);
?>
<form method="post">
<input name="sample" type="text">
<input type="submit" />
</form>

Can't reproduce on Multisite either.

comment:5 westi4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing as Works for Me based on comments above.

Note: See TracTickets for help on using tickets.