WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#16040 closed defect (bug) (maybelater)

Equal sign in URL causes problems on site name change

Reported by: bfred.it Owned by:
Milestone: Priority: lowest
Severity: normal Version: 3.1
Component: Administration Keywords: has-patch needs-testing close
Focuses: Cc:

Description

Steps to reproduce the problem:
Create a WP site at a url like: http://localhost/~Fede/=test/3.1/
Go here to change the site name: http://localhost/~Fede/=test/3.1/wp-admin/options-general.php

The name will be changed, but you will be redirected to a wrong URL: http://localhost/~Fede/=test%2F3.1%2Fwp-admin%2Foptions-general.php&settings-updated=true

I assume the problem is caused by the = sign, as other websites under http://localhost/~Fede/ don't have the same problem.

I tried it on 3.0.4 and 3.1-RC1

Attachments (1)

16040.patch (472 bytes) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (6)

SergeyBiryukov3 years ago

comment:1 SergeyBiryukov3 years ago

  • Keywords has-patch added

comment:2 SergeyBiryukov3 years ago

  • Keywords needs-testing added

comment:3 bfred.it3 years ago

16040.patch solved the problem on 3.0.4, 3.1RC1 and 3.1RC2, HOWEVER:

  • the logout link in the admin is changed to: http://_wpnonce=9b5ccb0215
  • when trying to change the site's urlS (which were also affected by the initial problem) you get redirected to "http://reauth%3D1", and to the "home" link is not updated in the database.
Last edited 3 years ago by bfred.it (previous) (diff)

comment:4 nacin3 years ago

  • Keywords close added
  • Priority changed from normal to lowest

It's a reserved character, so this is too hard to tell whether the browser is just silently decoding it on display for you. I'm not a fan of spending any time trying to fix this.

comment:5 westi3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

Reproduced in trunk.

I agree that this is too edge to worry about now.

Note: See TracTickets for help on using tickets.