WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16068 closed enhancement (duplicate)

No UI for "unscheduling" a scheduled post?

Reported by: RanYanivHartstein Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: UI Keywords: ux-feedback
Focuses: Cc:

Description

When you schedule a post for future publishing, there seems to be no easy way to change your mind and to publish it immediately.

To reproduce:

  1. Create a new post and click on "Edit" next to "Publish".
  1. Pick any date in the future and click on OK next to the date.
  1. Click on Schedule.
  1. Now, try to publish the post immediately.

As far as I can tell, the only way to immediately publish a scheduled post is to change the schedule to sometime in the very near future - like five minutes from now.

However, it's a bit of a hack and many users are likely to either not think about that as a possible solution, or to spend some time looking for a proper solution and become frustrated.

I suggest we add "Reset schedule" or "Cancel schedule" option when you click on Edit next to Scheduled in the Publish box. For example, see this very crude mock-up:
http://cl.ly/2c3h141V2w1O1l1f1l3e

Note that there were several other related tickets - #8368
#7833 #8737 - but it's not entirely clear if they are indeed referring to this particular enhancement.

Attachments (1)

16068-radio-inputs.diff (1.1 KB) - added by lancewillett 5 years ago.
Start of a patch to add radio inputs that I worked on at WC Phx

Download all attachments as: .zip

Change History (13)

comment:1 follow-up: @SergeyBiryukov5 years ago

Works as expected for me:

  1. Write a post.
  2. Change the date to a month ahead.
  3. Click Schedule. The post status changes to Scheduled.
  4. Change the date to the current month again.
  5. Click Publish. The post status changes to Published.

comment:2 @SergeyBiryukov5 years ago

  • Keywords ux-feedback added

comment:3 in reply to: ↑ 1 @RanYanivHartstein5 years ago

Replying to SergeyBiryukov:

Works as expected for me:

Why would you say this is "expected"?

Lets say there are two publishing options - "Publish Now" and "Scheduled Publishing".

We all use "Publish Now" most of the time, and we don't have to enter a date to do it.

Why should you have to enter a date to do "Publish Now" just because you happened to do "Scheduled Publishing" on the same post before?

If anything, it's unexpected.

comment:4 @jane5 years ago

At one point I think clicking Cancel would return state to Publish Immediately (I vaguely remember it being a topic of discussion a couple of releases ago), but that was overriding the normal ok/cancel behavior. I've never had any problem with setting the date and time back to right now manually. Is it really that hard to look up in the corner of your computer screen to see what time it is and enter it? I'm all for making the UI easier, but in cases where the use case is relatively narrow, we have to weigh adding more stuff to reduce work on the part of the user needing the new behavior with adding clutter for all the users that don't need the behavior. If we had any stats on how often a post goes from being scheduled to being published immediately that would be useful.

I'd suggest a plugin, but let's face it, such a small change to UI probably wouldn't get a lot of publicity in the world of plugins. Maybe wordpress.com (and/or any other person/business out there running a customized/hosted WP setup that could gather stats on usage) could implement a feature like this, and we could observe the usage stats for a while to help determine if it's needed for core.

In meantime, adding this tickt to UI group's list of UI issues that might need addressing.

comment:5 @jane5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

#8368 does, indeed, include this issue. Closing this one as dupe.

comment:6 @ocean905 years ago

  • Milestone Awaiting Review deleted

comment:7 @JohnONolan5 years ago

Does this need a UI? Surely when you edit the schedule date the "cancel" link should just remove the schedule. It works like this if you edit the schedule date multiple times prior to actually scheduling the post.

comment:8 follow-up: @JohnONolan5 years ago

I take it back - I understand the issue now. Here's my proposed solution: http://cl.ly/452E

Also, why "immediately" ? Why not "now" or "right now"

Last edited 5 years ago by JohnONolan (previous) (diff)

comment:9 in reply to: ↑ 8 @jane5 years ago

Also, why "immediately" ? Why not "now" or "right now"

The language was inherited. I think the implication is "Immediately (on Publish)."

comment:10 @jane5 years ago

The radio buttons work for me.

comment:11 @saracannon5 years ago

  • Cc sararcannon@… added

@lancewillett5 years ago

Start of a patch to add radio inputs that I worked on at WC Phx

comment:12 @garyc405 years ago

Just in case someone is following this ticket instead of the old one (#8368), there's another patch for this issue that needs testing and feedback: 8368.diff

Note: See TracTickets for help on using tickets.