WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#1610 closed defect (bug) (fixed)

Paragraph tags stored in post_content when using TinyMCE

Reported by: markjaquith Owned by: markjaquith
Milestone: Priority: normal
Severity: normal Version: 2.0.2
Component: Administration Keywords: bg|needs-patch
Focuses: Cc:

Description

We should definitely be converting <p></p> and <br /> to line breaks before storing the post in post_content

If you switch away from the WYSIWYG editor, your posts are impossible to edit.

Change History (6)

comment:1 markjaquith8 years ago

  • Status changed from new to assigned

comment:2 skeltoac8 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Done.

comment:3 micdobro8 years ago

  • Component changed from General to Administration
  • Priority changed from normal to high
  • Resolution fixed deleted
  • Severity changed from major to critical
  • Status changed from closed to reopened
  • Version changed from 1.6 to 2.0.2

The problem is, that in WP 2.0.2 where TinyMCE is integrated it is really painfull to see your pages without any line breaks/paragraphs. I understand backward compatibility, but why these golden handcuffs have to be so painful?

comment:4 skeltoac8 years ago

  • Priority changed from high to normal
  • Resolution set to fixed
  • Severity changed from critical to normal
  • Status changed from reopened to closed
  • Version changed from 2.0.2 to 2.0

This was fixed months ago. Do not reopen tickets for bugs that do not exist.

If you have a bug, you should report it with full details and with realistic priority/severity. Your comment above has absolutely no details and is therefore useless to any developer who would like to help you.

comment:5 micdobro8 years ago

  • Version changed from 2.0 to 2.0.2

You are absolutely right. I do apologize for this. I found solution for the problem a few moments ago.

comment:6 anonymous7 years ago

  • Milestone 2.0 deleted

Milestone 2.0 deleted

Note: See TracTickets for help on using tickets.