WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 12 months ago

Last modified 12 months ago

#16202 closed enhancement (duplicate)

Add support to get_pages() to allow multiple exclude_tree exclusions

Reported by: jefsnare Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Template Keywords:
Focuses: Cc:

Description (last modified by dd32)

get_pages() does not support the use of multiple parents in the exclude_tree arguement.

The attached patch allows for a comma seperated list to be passed.

Attachments (1)

exclude_tree.patch (1.1 KB) - added by jefsnare 3 years ago.

Download all attachments as: .zip

Change History (4)

jefsnare3 years ago

comment:1 dd323 years ago

  • Component changed from Menus to Template
  • Description modified (diff)
  • Keywords needs-patch added; exclude tree post removed
  • Milestone changed from Awaiting Review to Future Release
  • Summary changed from Exclude tree bug to Add support to get_pages() to allow multiple exclude_tree exclusions
  • Type changed from defect (bug) to enhancement

The attached patch needs to be updated to allow an array to be passed.

comment:2 SergeyBiryukov12 months ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Status changed from new to closed

Duplicate of #9153.

comment:3 SergeyBiryukov12 months ago

  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.