WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 15 months ago

#16248 closed defect (bug) (invalid)

Back to Authors and Users link redirects to nowhere from a paginated user-edit screen

Reported by: linuxologos Owned by: PeteMall
Milestone: Priority: high
Severity: critical Version: 3.1
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

Testing against 3.1-RC2-17283.

Go to Users and go to any page other than the first one (the screen has to be paginated). Edit a User at that page and save. The Back to Authors and Users link redirects to a page just showing "-1". The problem is quite obvious even from the browser's address bar, which reveals the strange value for wp_http_referer (it must be related to ajaxified screens).

Attachments (3)

16248.diff (4.5 KB) - added by scribu 4 years ago.
16248.2.diff (4.5 KB) - added by PeteMall 4 years ago.
16248.3.diff (5.1 KB) - added by PeteMall 4 years ago.
Fixed ajax search query vars.

Download all attachments as: .zip

Change History (14)

comment:1 @nacin4 years ago

  • Milestone changed from Awaiting Review to 3.1

comment:2 @PeteMall4 years ago

Screens affected:

  • site admin users
  • net admin users
  • net admin site-users

comment:3 @PeteMall4 years ago

  • Priority changed from normal to high
  • Severity changed from normal to critical

This is happening because the referrer is changed to admin-ajax.php with the JS pagination/search. We'll need to fix this for all list tables.

comment:4 @scribu4 years ago

It should be a simple matter of passing _wp_http_referrer to the 'fetch-list' ajax action.

comment:5 @scribu4 years ago

  • Owner set to scribu
  • Status changed from new to accepted

comment:6 @scribu4 years ago

  • Keywords has-patch added

The problem was that these screens used 'wp_http_referrer' instead of '_wp_http_referrer'.

@scribu4 years ago

comment:7 @scribu4 years ago

  • Keywords commit added

comment:8 @nacin4 years ago

  • Keywords commit removed

PeteMall said this doesn't work in all cases; he'll work through it tomorrow. Something about paging.

@PeteMall4 years ago

@PeteMall4 years ago

Fixed ajax search query vars.

comment:9 @PeteMall4 years ago

  • Owner changed from scribu to PeteMall

comment:10 @PeteMall4 years ago

  • Resolution set to invalid
  • Status changed from accepted to closed

Closing this as invalid because of #16262. See #16275 for a related no-js bug.

comment:11 @SergeyBiryukov15 months ago

  • Milestone 3.1 deleted
Note: See TracTickets for help on using tickets.