WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 12 months ago

Last modified 12 months ago

#16254 closed enhancement (duplicate)

Reset password message should show Site address, not WordPress address

Reported by: moskjis Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.0.4
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

It's possible for site to have different address than the one Wordpress is in. If it's so, when site user has forgotten his / her password and resets it, the message he / she gets is like this:

Someone has asked to reset the password for the following site and username.
<Wordpress URL here>
Username: <username here>
To reset your password visit the following address, otherwise just ignore this email and nothing will happen.

<Wordpress URL here> should be changed to <Site URL here>

As to how to change: see attached patch.
network_site_url function changed to home_url function.

Attachments (2)

wp-login.patch (741 bytes) - added by moskjis 3 years ago.
wp-login.2.patch (749 bytes) - added by moskjis 3 years ago.

Download all attachments as: .zip

Change History (7)

moskjis3 years ago

comment:1 nacin3 years ago

  • Milestone changed from Awaiting Review to 3.1

Should be network_home_url().

comment:2 moskjis3 years ago

Agree, added updated patch: wp-login.2.patch.

Last edited 3 years ago by moskjis (previous) (diff)

moskjis3 years ago

comment:3 nacin3 years ago

  • Component changed from Mail to Administration
  • Keywords has-patch added
  • Milestone changed from 3.1 to Future Release

Not a regression.

comment:4 SergeyBiryukov12 months ago

  • Milestone Future Release deleted
  • Status changed from new to closed

Duplicate of #19767. Fixed in [19705].

comment:5 SergeyBiryukov12 months ago

  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.