WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 20 months ago

#16256 closed defect (bug) (worksforme)

Internal Link don't support Chinese language

Reported by: wpchina Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Query Keywords: reporter-feedback
Focuses: Cc:

Description

The Internal Link in WordPress 3.1 do help to SEO. It is a great tool to webmasters. While the feature don't support Chinese or other non-English characters. I hope this issue can be fixed in 3.1 final release.

Attachments (1)

chinese.jpg (18.3 KB) - added by liuxyon 3 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 ocean903 years ago

  • Keywords reporter-feedback added; Internal Link non-English characters Chinese removed

What is the problem in detail here?

comment:2 nacin3 years ago

I've asked the same question at http://wordpress.org/support/topic/internal-link-dont-support-chinese-language and I really don't have a clue what the bug is.

comment:3 nacin3 years ago

Perhaps we're not properly encoding the search?

comment:4 SergeyBiryukov3 years ago

Can't reproduce either. What are the exact steps?

comment:5 liuxyon3 years ago

1.just you upload files of chinese file name and it will can't work.

2.when your the post tile name is chinese. then the chinese url can't work.

comment:6 SergeyBiryukov3 years ago

And what the exact file name or post title should look like? Please give some examples.

Version 1, edited 3 years ago by SergeyBiryukov (previous) (next) (diff)

comment:7 SergeyBiryukov3 years ago

I'm asking for some real examples because I've already tested Internal Linking with “Hello World” translated to Chinese (via Google Translate) and it seemed to work fine.

liuxyon3 years ago

comment:9 follow-up: nacin3 years ago

What does that have to do with internal linking?

comment:10 in reply to: ↑ 9 liuxyon3 years ago

Replying to nacin:

What does that have to do with internal linking?

what is do you mean? I am using IIS6.0 PHP5.3.4 FASICGI MODE, just I upload chinese file,but it isn't show.

comment:11 liuxyon3 years ago

and http://www.xiaoyuxa.com/tag/远端控制 chinese url cant open address as well.

comment:12 SergeyBiryukov3 years ago

As for the slug, it works fine on Apache, so it might be an IIS configuration issue.

As for the file name, it doesn't work on Windows indeed. Looks like a duplicate of #15955.

As for Internal Linking, the ticket description might be inaccurate from the start.

comment:13 liuxyon3 years ago

it should not IIS issue, I have try use unix hosting, chinese URL not work.

comment:14 follow-up: ocean903 years ago

liuxyon, please explain in more than one/two sentences what the problem with the internal linking is about.

comment:15 in reply to: ↑ 14 liuxyon3 years ago

Replying to ocean90:

liuxyon, please explain in more than one/two sentences what the problem with the internal linking is about.

maybe I find upload chinese file name, it isn't download reason.

Because when I upload chinese name file via wordpress admin control after, then the file name be force change other encode file name. maybe is utf-8?

such as:

The real chinese file name is: 完美GPS信息_Ulysee Gizmos_1.5.2.rar

upload via WP after file name change to:
瀹岀編GPS淇℃伅_Ulysee-Gizmos_1.5.2.rar

comment:16 nacin20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.