WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 21 months ago

Last modified 21 months ago

#16258 closed defect (bug) (worksforme)

nav menus dont save the right type of menu items

Reported by: J0rDZ Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.0.4
Component: Administration Keywords: reporter-feedback
Focuses: Cc:

Description

the new Navigation menus when the flag is set "Automatically add new top-level pages" when adding a new page to the menu and saves the new menuitem will change from "page" to "userdefined" as type.

It is always only the last item in the menu there is changeing.

Change History (7)

comment:1 @J0rDZ4 years ago

An image of the problem can be found here: http://www.webcomfort.dk/nav_problem_wp.jpg

comment:2 @garyc404 years ago

Can't reproduce. Could you try on a pristine install of WordPress?

comment:3 follow-up: @nacin4 years ago

  • Keywords reporter-feedback close added; nav menu menuitem types removed

'userdefined isn't a string in core. This is probably a plugin.

comment:4 in reply to: ↑ 3 @kawauso4 years ago

Replying to nacin:

'userdefined isn't a string in core. This is probably a plugin.

#: wp-includes/nav-menu.php:580
msgid "Custom"
msgstr "Brugerdefineret"

It's just an odd translation.

comment:5 @nacin4 years ago

  • Keywords close removed

Removing 'close' then. Haven't tried to reproduce.

comment:6 @andrewspittle21 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Not reproducible in trunk nor 3.5.2. In each case new menu items remain set as "Page."

comment:7 @helen21 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.