Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#16265 closed defect (bug) (worksforme)

Theme installer - linux permissions block install - misleading error message.

Reported by: rathbone1200cc Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.4
Component: Upgrade/Install Keywords: reporter-feedback
Focuses: Cc:


My wordpress install is 3.0.4 on a linux server.

I ran the php-based theme installer with FTP account details. It looks like the installer created a temporary folder "upgrade" in the wp-content directory.

I ran the installer again with FTP account details for a different FTP account. It looks like the permissions of the leftover "upgrade" directory in the wp-content directory blocked the install process.

The error message for the problem was “username/password incorrect for ..." which was misleading.

I changed the permissions of the "upgrade" directory to 777 - and this has unblocked the install process.

Change History (3)

#1 @dd32
5 years ago

  • Keywords reporter-feedback added; Theme installer linux permissions removed

Just a quick question: Did both of these FTP Accounts have the "same" access to the WordPress installation? ie. Was one a higher privledge account than the other (if so, which one?), was one a different root directory? Same Group Name?

#2 @dd32
5 years ago

Also, Which FTP Server software is being used if you're aware of it?

#3 @dd32
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I can't duplicate this.

In the event of the folder either being a) unaccessable or b) unwritable (ie. chmod 444) the process always makes it past the FTP login screen.

In testing, the error's likely to be hit in this scenario are:

Could not create directory. /public_html/dd32.id.au/wordpress/wp-content/upgrade

Marking as worksforme for now pending reporter-feedback.

Note: See TracTickets for help on using tickets.