WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 5 years ago

#1628 closed defect (bug) (wontfix)

Error when posting - Cannot modify header information

Reported by: adame Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0.3
Component: Administration Keywords: post.php headers posting
Focuses: Cc:

Description

When editing a post I sometimes receive the following error message:

Warning: Cannot modify header information - headers already sent by (output started at /home/aparks/public_html/wp-includes/comment-functions.php:516) in /home/aparks/public_html/wp-admin/post.php on line 110

It's really annoying. Any help would be appreciated.

Change History (12)

comment:1 markjaquith9 years ago

  • Milestone set to 1.6

I saw someone else report this as well. We need to move pingbacks to shutdown, but still, it would be nice to find out what is causing this.

comment:2 markjaquith9 years ago

Can you please update to the latest SVN revision and try again?

This changeset probably fixed this error:
http://trac.wordpress.org/changeset/2828

comment:3 masquerade8 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

No problems, and no similar reports in over a month, no need to keep this open.

comment:4 masquerade8 years ago

  • Keywords bg|squashed added

comment:5 fsmg8 years ago

  • Keywords post.php|headers|posting added; bg|squashed removed
  • Resolution worksforme deleted
  • Severity changed from major to critical
  • Status changed from closed to reopened
  • Version changed from 1.6 to 2.0.3

I'm having this problem too!! It's really annoying!!

comment:6 Viper007Bond8 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

No problems here.

Please check to make sure that you have the latest SVN copy and that all files are complete.

comment:7 fsmg8 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have 2.0.3 and I have reinstalled it! Can you point me to some files that I can overwrite the functions file and post.php?

comment:8 masquerade8 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

99.999999999999999% of the time, this is a plugin issue. Unless you have tried disabling all plugins and made sure you uploaded your files properly, please don't reopen the ticket without more details or evidence that this is caused by WP.

comment:9 fsmg8 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hey, ok, deactivated all my plugins, didn't work! I then reinstalled WP, and what happend was that when I write a new page/post, for some reason, FireFox downloads post.php!

comment:10 foolswisdom8 years ago

  • Keywords post.php headers posting added; post.php|headers|posting removed
  • Milestone 2.0 deleted
  • Priority changed from high to normal
  • Resolution set to worksforme
  • Severity changed from critical to normal
  • Status changed from reopened to closed

fsmg, for the "downloads post.php" there are a number of related threads on http://wordpress.org/support , do any apply to your situation? Please be as detailed as possible in what you have tried, etc when updating bug reports -- often better to seek suport first.

Closing bug as worksforme.

comment:11 vasanthakumar5 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:12 DD325 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

Bug is over 2 years old. Original bug report was found to not exist, If you're experiencing the same thing, Please try the support forums first, or, perhaps, with the default theme & plugins deactivated, and then the forum.

If You work out its a bug in WP, Open a new ticket rather than re-opening a ancient one.

Note: See TracTickets for help on using tickets.