WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16300 closed defect (bug) (duplicate)

can't delete admin account (account #1)

Reported by: hughestm@… Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: General Keywords:
Focuses: Cc:

Description

In 3.0.4 -> /wp-admin/ms-edit.php line 499 -> it's hard coded to not delete account if you pass $id of 0 or 1.
In 3.1rc2 -> /wp-admin/network/edit.php line 359 -> same code

The problem is that it's looking for hard coded values to not delete. It should check to see if you have another user set as super_admin, and if so, then allow you to delete this account.

From IRC (#wordpress-dev):

hughestm
checking hard values -> not checking to see if you have other super_admins

PeteMall
yea... that doesn't seem right
Jan 18 21:48:30 +0000 2011

Change History (2)

comment:1 SergeyBiryukov3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 ocean903 years ago

  • Keywords delete admin multisite network removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.