WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16305 closed defect (bug) (invalid)

Editor causes errors when making changes

Reported by: bspr3663 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: General Keywords:
Focuses: Cc:

Description

After I switched to a new server and moved over my wordpress files and database I have ran into an editor issue. Whenever I make a change on a file it causes an error. I know my coding is correct because when I edit the file in dreamweaver and then ftp it over it works fine.

Change History (9)

comment:1 nacin3 years ago

And the errors are?

comment:2 bspr36633 years ago

I found out it's only the header.php file in the editor. I'm getting this error:

Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in /home/content/80/7256080/html/wp-content/themes/TheSource/header.php on line 96

and all I did is change the number 7 to 5

comment:3 moskjis3 years ago

Can you give more info, please?
Source code for your theme header.php file would be good (at least, the part where the error is).

comment:4 bspr36633 years ago

You know when I switch over database it messed up a lot, for example on functions.php file it add two extra lines, which then made it so it wouldn't work (which I fixed), so I wouldn't doubt it if it added some kind of extra coding to the header.php file.


echo "<link rel=\"image_src\" href=\"".$image[0]."\" / >";

<?php global $default_colorscheme, $shortname, $category_menu, $exclude_pages, $exclude_cats, $hide, $strdepth, $strdepth2, $page_menu; ?>
<?php $colorSchemePath = '';
	  $colorScheme = get_option($shortname . '_color_scheme');
      if ($colorScheme <> $default_colorscheme) $colorSchemePath = strtolower($colorScheme) . '/'; ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
<title><?php elegant_titles(); ?></title>
<?php elegant_description(); ?>
<?php elegant_keywords(); ?>
<?php elegant_canonical(); ?>

<link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />
<link rel="alternate" type="application/atom+xml" title="<?php bloginfo('name'); ?> Atom Feed" href="<?php bloginfo('atom_url'); ?>" />
<link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />

<!--[if lt IE 7]>
	<link rel="stylesheet" type="text/css" href="<?php bloginfo('template_directory'); ?>/css/ie6style.css" />
	<script type="text/javascript" src="<?php bloginfo('template_directory'); ?>/js/DD_belatedPNG_0.0.8a-min.js"></script>
	<script type="text/javascript">DD_belatedPNG.fix('img#logo, #cat-nav-left, #cat-nav-right, #search-form, #cat-nav-content, div.top-overlay, .slide .description, div.overlay, a#prevlink, a#nextlink, .slide a.readmore, .slide a.readmore span, .recent-cat .entry .title, #recent-posts .entry p.date, .footer-widget ul li, #tabbed-area ul#tab_controls li span');</script>
<![endif]-->
<!--[if IE 7]>
	<link rel="stylesheet" type="text/css" href="<?php bloginfo('template_directory'); ?>/css/ie7style.css" />
<![endif]-->
<!--[if IE 8]>
	<link rel="stylesheet" type="text/css" href="<?php bloginfo('template_directory'); ?>/css/ie8style.css" />
<![endif]-->

<script type="text/javascript">
	document.documentElement.className = 'js';
</script>

<?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>


<!-- fancybox -->
<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js"></script>
	<script type="text/javascript" src="http://www.boisestatepublicradio.org/fancybox/jquery.mousewheel-3.0.4.pack.js"></script>
	<script type="text/javascript" src="http://www.boisestatepublicradio.org/fancybox/jquery.fancybox-1.3.2.js"></script>
	<link rel="stylesheet" type="text/css" href="http://www.boisestatepublicradio.org/fancybox/jquery.fancybox-1.3.2.css" media="screen" />
 
	<script type="text/javascript">
		$(document).ready(function() {
			/*
			*   Examples - images
			*/

			

			$("#ll").fancybox({
				'width'				: 710,
				'height'			: 350,
				'autoScale'			: false,
				'transitionIn'		: 'elastic',
				'transitionOut'		: 'elastic',
				'type'				: 'iframe'
			});
$("#smartphone").fancybox({
				'width'				: 720,
				'height'			: 465,
				'autoScale'			: false,
				'transitionIn'		: 'elastic',
				'transitionOut'		: 'elastic',
				'type'				: 'iframe'
			});
$("#fulliframe").fancybox({
				'width'				: '90%',
				'height'			: '90%',
				'autoScale'			: false,
				'transitionIn'		: 'none',
				'transitionOut'		: 'elastic',
				'type'				: 'iframe'
			});
$("#smalliframe").fancybox({
				'width'				: '50%',
				'height'			: '70%',
				'autoScale'			: false,
				'transitionIn'		: 'elastic',
				'transitionOut'		: 'none',
				'type'				: 'iframe'
			});
			
		});
	</script>
<!-- fancy box end -->


<!-- ADDED CODE facebook meta tag img post -->
<?php global $wp_query;
$thePostID = $wp_query->post->ID;
if( has_post_thumbnail( $thePostID )){
$thumb_id = get_post_thumbnail_id( $thePostID );
$image = wp_get_attachment_image_src( $thumb_id );
echo "<link rel=\"image_src\" href=\"".$image[0]."\" / >";
}?>
<!-- END of facebook -->
<?php wp_head(); ?>

<link rel="shortcut icon" href="<?php bloginfo('template_directory'); ?>/favicon.ico" />
</head>
<body<?php if (is_home()) echo(' id="home"'); ?>>


<!-- ADDED CODE (Login tab) -->
	<div class="tab">
		<div class="login">
	    	<div class="left">&nbsp;</div>
	    	<!-- Logout -->
	        <div><a style="font-family (stack): Arial,Verdana,sans-serif; color:#999999; font-size: 12px; letter-spacing: normal; word-spacing: normal; font-weight: bold" href="http://www.boisestatepublicradio.org/comment-community/">Comment Community</a><img src="http://www.boisestatepublicradio.org/wp-content/uploads/2010/09/IconRegister.png"><?php wp_register(); ?><img src="http://www.boisestatepublicradio.org/wp-content/uploads/2010/09/IconLogin.png"><?php wp_loginout(); ?><?php wp_meta(); ?> </div>
			
			
	    	<div class="right">&nbsp;</div>
		</div> 
	</div> 
<!-- / END OF Login Tab -->
	<div id="header-top" class="clearfix">




		<div class="container clearfix">
			<!-- Start Logo -->
			<a href="<?php bloginfo('url'); ?>">
				<img src="<?php bloginfo('template_directory'); ?>/images/<?php if ( $colorScheme == 'Light' || $colorScheme == 'Red' || $colorScheme == 'Blue') echo($colorSchemePath); ?>logo.png" alt="Boise State Public Radio" id="logo"/>
			</a>
			<p id="slogan"><?php bloginfo('description'); ?></p>
			<!-- End Logo -->
			
			<!-- Start Page-menu -->
			<div id="page-menu">
				<div id="p-menu-left"> </div>
				<div id="p-menu-content">
				
					<?php $menuClass = 'nav clearfix';
					$primaryNav = '';
					
					if (function_exists('wp_nav_menu')) $primaryNav = wp_nav_menu( array( 'theme_location' => 'primary-menu', 'container' => '', 'fallback_cb' => '', 'menu_class' => $menuClass, 'echo' => false ) );
					if ($primaryNav == '') show_page_menu($menuClass);
					else echo($primaryNav); ?>
				
				</div>	
				<div id="p-menu-right"> </div>
			</div>	<!-- end #page-menu -->	
			<!-- End Page-menu -->
	

            
            <!-- bottom navigation -->
            <div style="background: url(http://www.boisestatepublicradio.org/wp-content/themes/TheSource/images/bottom-nav-bg.png) repeat-x; height: 57px; position:fixed;right:0px;left:0px;bottom:0px; z-index:1;"><a href="http://www.boisestatepublicradio.org/programming"><img align="middle" src="http://www.boisestatepublicradio.org/wp-content/themes/TheSource/images/bottom-nav-programming.png" /></a><img align="middle" src="http://www.boisestatepublicradio.org/wp-content/themes/TheSource/images/bottom-nav-hr.png" /><a href="http://www.boisestatepublicradio.org/music" ><img align="middle" src="http://www.boisestatepublicradio.org/wp-content/themes/TheSource/images/bottom-nav-music.png" /></a><img align="middle" src="http://www.boisestatepublicradio.org/wp-content/themes/TheSource/images/bottom-nav-hr.png" /><a  href="http://www.boisestatepublicradio.org/podcasts"><img align="middle" src="http://www.boisestatepublicradio.org/wp-content/themes/TheSource/images/bottom-nav-podcasts.png" /></a><img align="middle" src="http://www.boisestatepublicradio.org/wp-content/themes/TheSource/images/bottom-nav-hr.png" /><a href="https://secure.modwest.com/boisestateradio.modwest.com/pps_production/public_membership/index.php?sourceCode=WhiteBoxDonate" ><img align="middle" src="http://www.boisestatepublicradio.org/wp-content/themes/TheSource/images/bottom-nav-donate.png" /></a></div>
            <!-- end -->


			<div id="cat-nav" class="clearfix">	
				<div id="cat-nav-left"> </div>
				<div id="cat-nav-content"> 
					
					<?php $menuClass = 'superfish nav clearfix';
					$secondaryNav = '';
					
					if (function_exists('wp_nav_menu')) $secondaryNav = wp_nav_menu( array( 'theme_location' => 'secondary-menu', 'container' => '', 'fallback_cb' => '', 'menu_class' => $menuClass, 'echo' => false ) );
					if ($secondaryNav == '') show_categories_menu($menuClass);
					else echo($secondaryNav); ?>

					<!-- Start Searchbox -->
					<div id="search-form">
						<form method="get" id="searchform1" action="<?php bloginfo('url'); ?>">
							<input type="text" value="<?php _e('search...','TheSource'); ?>" name="s" id="searchinput" />
		
							<input type="image" src="<?php bloginfo('template_directory'); ?>/images/<?php echo($colorSchemePath); ?>search_btn.png" id="searchsubmit" />
						</form>
					</div>
				<!-- End Searchbox -->	
				</div> <!-- end #cat-nav-content -->

				<div id="cat-nav-right"> </div>
			</div>	<!-- end #cat-nav -->	
		</div> 	<!-- end .container -->
	</div> 	<!-- end #header-top -->
	
	
	
	<?php if ( (is_home() || is_front_page()) && get_option('thesource_featured') == 'on' ) include(TEMPLATEPATH . '/includes/featured.php'); ?>


	
	<div id="content">
		<?php if (!is_home()) { ?>
			<div id="content-top-shadow"></div>



<!-- inserted text (http://codex.wordpress.org/Category_Templates) -->

<?php if (is_category('a')) { ?>
<!-- I left this option blank -->a
<?php } elseif (is_category('station_highlights')) { ?>
<!-- content slide -->
<center><div style="width: 1000px; height: 200px; background: #ffffff; border: #9a0000 solid 12px;"><?php include (ABSPATH . '/wp-content/plugins/content-slide/slideshow.php'); ?></div></center>
<!-- end of content slide -->
<?php } ?>

<! -- end -->



		<?php }; ?>
		<div class="container">

Edited by ocean90: Please use the code tags.

Last edited 3 years ago by ocean90 (previous) (diff)

comment:5 Moskjis3 years ago

bspr3663, this is not a Wordpress error. Ergo, this is not the place to ask for help about it. Theme developer or http://wordpress.org/support/forum/how-to-and-troubleshooting would be better places. Keep in mind that wordpress.org/support is run by volunteers, meaning, no one is obligated to help you.
As to the error, my guess would be that you have wrong file or end of line encoding. But, can't tell for sure, would need to see the file itself.

Version 0, edited 3 years ago by Moskjis (next)

comment:6 ocean903 years ago

  • Keywords database editor error removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

See Moskjis's comment.

comment:7 bspr36633 years ago

  • Keywords database editor error added

Are you guys sure it's not a wordpress error. Cause the code works, it is properly coded, why I know this is because if I ftp the file it displays the website correctly and also updates the file in wordpress. But when i edit the file in wordpress and update the file it displays the error. So if I update the file in dreamweaver and then ftp it works. If I need to get help from somewhere else I will, just wasn't sure if you understood the problems I am having.

comment:8 Moskjis3 years ago

Have you tried reuploading Wordpress files themselves? Maybe some of them are corrupt. Other than that, can you reproduce this problem on clean Wordpress install? I can't.
If you can, more information about your environment would be needed.

comment:9 ocean903 years ago

  • Keywords database editor error removed

If you have problems, you can use our support forums

http://wordpress.org/support/

Note: See TracTickets for help on using tickets.