WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#16321 closed defect (bug) (duplicate)

Unmoderated comments cause dashboard to break

Reported by: brianfreytag Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: close
Focuses: Cc:

Description

I have noticed that when one of our website generates too many spam comments that go unmoderated, the dashboard breaks. It displays a blank white page (white page of death).

It appears that by simply bypassing the dashboard (going to /admin/plugins.php or something like that), then navigating to the comments, then deleting those spam messages fixes the issue and allows the dashboard to load properly.

Change History (5)

comment:1 follow-up: nacin3 years ago

  • Keywords close added

This sounds like a duplicate of #14222.

comment:2 in reply to: ↑ 1 brianfreytag3 years ago

Replying to nacin:

This sounds like a duplicate of #14222.

This is not a duplicate of ticket #14222. This is a dashboard breakage... It's not just taking a long time to load. It simply does not load.

comment:3 follow-up: nacin3 years ago

Yes, I get that. What I'm saying is that the problem is likely the same as #14222. We go into a while() loop to fetch comments, and then exclude the spam comments in PHP.

Taking a long time to load can lead into not loading at all, if memory is exhausted. With enough comments, that would happen.

Can you try out http://core.trac.wordpress.org/attachment/ticket/14222/14222.2.patch and see how it goes? Maybe just execute the SQL against the database and see how long it takes (and please tell us the number of rows in that table, and how many are spam) -- it'd look like this:

SELECT * FROM wp_comments c LEFT JOIN wp_posts p ON c.comment_post_ID = p.ID WHERE c.comment_approved IN (0,1) AND p.post_status != 'trash' ORDER BY c.comment_date_gmt DESC LIMIT 0, 50

comment:4 in reply to: ↑ 3 brianfreytag3 years ago

I will have to wait for a large number of spam comments to accumulate before I can truly test it.

comment:5 scribu3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I agree that the cause is the same, just that the symptom is more severe in your case.

Closing as dup of #14222

Note: See TracTickets for help on using tickets.