Make WordPress Core

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#16368 closed defect (bug) (worksforme)

XML-RPC posting adds default category

Reported by: pixelgeek's profile pixelgeek Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.0.4
Component: XML-RPC Keywords:
Focuses: Cc:

Description

When posting to a Wordpress 3.04 blog using a blog editing tool such as MarsEdit or Ecto the default category is always added even if there are other categories added to the post.

Prior to 3.04 if a post was made with these tools the default category was only added when there were no categories specified for the post.

I attempted to enable XML-RPC logging but on my server the file was not being created when logging was enabled.

Change History (8)

#1 @Moskjis
13 years ago

Don't have MAC, can't test the programs mentioned, but BlogDesk works correctly on 3.04 production site. The category selected wasn't default one (defined in Settings => Writing), was added correctly to the uploaded post too.

#2 @pixelgeek
13 years ago

Just an update.

I have the same issue posting to a Wordpress.com hosted blog as I do to my blog.

#3 @ericmann
13 years ago

I can't reproduce this on a PC ... and I am unable to test with a Mac. Is there a chance this is just happening with your specific software? Have you tried with other remote publishing systems? Can anyone else on a Mac with these remote tools confirm?

#4 @pixelgeek
13 years ago

Two different pieces of software isn't too specific though. I only got ecto on my machine to test to see if it was MarsEdit.

If it is a software related issue then I'm not sure why it would have started occurring with 3.04?

BTW does anyone know who enabling XML-RPC logging in the XML-RPC.php file doesn't appear to create a log file?

#5 @pixelgeek
13 years ago

Problem does not occur under Windows using w.bloggar. So it looks like either a Mac issue or an issue that effects ecto and MarsEdit

#6 @nprasath002
13 years ago

  • Cc n.prasath.002@… added

I tested with a Java client and it works fine in 3.1

#7 @solarissmoke
13 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce either. Based on the comments above it looks to be an issue with some clients, and not with Wordpress. If you do think there is an issue please reopen with a sample of the XML struct that fails.

#8 @scribu
13 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.