WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#16374 closed defect (bug) (duplicate)

Flawed handling of some characters in %postname% and %pagename%

Reported by: solarissmoke Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.1
Component: Rewrite Rules Keywords:
Focuses: Cc:

Description

Say I write a post whose url is
http://example.com/wp/2011/01/hello-world/

All of the following requests cause wordpress to generate a 200 response and display the "Hello World" post:

http://example.com/wp/2011/01/-hello-world/
http://example.com/wp/2011/01/-hello-world--/
http://example.com/wp/2011/01/.-hello-world.--/

Same for pages. Basically, hyphens and dots (and possibly other characters) before/after the actual slug are just ignored.

Wordpress should either be 404'ing or redirecting such requests to the posts actual URL.

Change History (1)

comment:1 @dd325 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14773

Note: See TracTickets for help on using tickets.