WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16376 closed defect (bug) (invalid)

Search button not translatable on list table

Reported by: thomask Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.1
Component: I18N Keywords:
Focuses: Cc:

Description (last modified by nacin)

Search button on list table (e.g. /wp-admin/plugins.php - on the top) cannot be translated. if i understand it right, the problem is wp-admin/includes/class-wp-list-table.php, function search_box
<?php submit_button( $text, 'button', false, false, array('id' => 'search-submit') ); ?>
should be
<?php submit_button( __($text), 'button', false, false, array('id' => 'search-submit') ); ?>

Change History (5)

comment:1 thomask3 years ago

<?php submit_button( __($text), 'button', false, false, array('id' => 'search-submit') ); ?>

comment:2 nacin3 years ago

  • Description modified (diff)

Due to the way gettext works, that won't work either. But looking.

comment:3 nacin3 years ago

It gets translated here:

<?php $wp_list_table->search_box( __( 'Search Plugins' ), 'plugin' ); ?>

search_box() gets passed translated text as $text.

comment:4 thomask3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I'm VERY sorry - i have been using one plugin (Fluency), and that stupid plugin rewrite it for uknown reason (using javascript, so i have seen in live code the wrong value and not find it in .pot) :-(

comment:5 nacin3 years ago

  • Milestone Awaiting Review deleted

Not a problem, it happens.

Note: See TracTickets for help on using tickets.