WordPress.org

Make WordPress Core

Opened 3 years ago

Last modified 20 months ago

#16386 closed defect (bug)

Issues with broken wp-admin urls — at Initial Version

Reported by: segui Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Multisite Keywords: reporter-feedback
Focuses: Cc:

Description

Hi,

i've just finish a brand new distributed setup and i ran into 2 few issues.

A word about the setup:
2 servers involved both running on debian stable. Wordpress version is 3.0.4 +dfsg-1~bpo50+1.
The first one handeling client request and, through apache's rewriting and proxypass revers rules, ask another server and eventually get datas to send back to client.

Urls invoked by client ar on that form http://www.blah.com/~user/blog to be rewritten to http://user.blah.blah.com/

The first issue was with the settings side where url were not correctly rewritten due to, as far as it seems, a bug code.
The url called after trying to submit changes in the settings panel is not concatenated tu the base url site, ie: http://www.blah.com/~user/blog/wp-admin/options-general.php leads to http://www.blah.com/wp-admin/options-general.php?updated=true instead of http://www.blah.com/~user/blog/wp-admin/options-general.php?updated=true.

The second issue was on the dashboard part. Links, for example to configure, widgets are broken on the same way described above.

Here is a patch which fix this issue, just by concatenating site_url() in order to have a correct complete path just like everywhere else in the code (as far as i saw).... Is this relevant ?

Thanks,
Christophe

Change History (1)

segui3 years ago

Note: See TracTickets for help on using tickets.