WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#16394 closed defect (bug) (worksforme)

comment_class() doesn't show classes for logged in user's comment

Reported by: danixland Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: General Keywords: dev-feedback
Focuses: Cc:

Description

while testing a theme I'm designing, based off the toolbox theme by automattic, I found that on the latest svn revisions the comment_class() function doesn't show various classes which would help discriminate between registered and not registered users.
Checking the same theme on 3.0.4, classes like .byuser, .bypostauthor and .comment-author-{username} appears, while on svn (rev 17369) they don't.
Using the twentyten on both 3.0.4 and svn didn't solve anything, classes are still missing on svn while they show up in 3.0.4

I'm testing everything on a local linux system with multiple WordPress installs, this is my system data:

OS:
Debian etch 6.0 x86_64

uname -a
Linux blackpearl 2.6.32-5-amd64 #1 SMP Wed Jan 12 03:40:32 UTC 2011 x86_64 GNU/Linux

lighttpd -v
lighttpd/1.4.28 (ssl) - a light and fast webserver
Build-Date: Nov 12 2010 12:45:04

php5-cgi -v
PHP 5.3.3-7 with Suhosin-Patch (cgi-fcgi) (built: Jan 5 2011 10:32:06)
Copyright (c) 1997-2009 The PHPGroup
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH

mysql --version
mysql Ver 14.14 Distrib 5.1.49, for debian-linux-gnu (x86_64) using readline 6.1

WordPress svn rev 17369

Change History (2)

comment:1 garyc403 years ago

Can't reproduce on TwentyTen, current trunk [17369].

comment:2 markjaquith3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Couldn't reproduce either, using Twenty Ten:

<li class="comment byuser comment-author-admin bypostauthor odd alt thread-odd thread-alt depth-1" id="li-comment-2">

Note: See TracTickets for help on using tickets.