WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#16403 closed defect (bug) (invalid)

redirect_to and force_ssl_login sends to wrong protocol

Reported by: madtownlems Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

WP 3.0.4, multisite, force_ssl_login is TRUE.

http://www.mysite.com/wp-login.php?redirect_to=%2Fbar

After logging in, I'm brought to:

https://www.mysite.com/bar (note the s)

My siteurl, wpurl, etc are defined without the s

Change History (3)

#1 @solarissmoke
9 years ago

  • Keywords reporter-feedback added

redirect_to is supposed to be an absolute URL including protocol, not a relative one. Is Wordpress generating the redirect_to or are you doing this with a plugin?

#2 @madtownlems
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

It was a plugin - and it is corrected now. While I wish WP would've handled this differently, I guess technically it's not a bug.
Thanks solarissmoke much for your assistance.

#3 @ocean90
9 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.