Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#16424 closed defect (bug) (duplicate)

Unable to publish new post of custom type if the custom type name is too long

Reported by: biq Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.0.4
Component: General Keywords:
Focuses: Cc:


If a custom type is created with name that is longer than 25 characters (wp_posts.post_type size is 25) then, when user wants to create a new post of that type, the button "Publish" is replaced with "Submit for review". This "Submit for review" does not work correctly (of course).

The supposed behaviour : Check somewhere the length of the custom type name and show a readable error.

The current behaviour : The user is confused.. there are multiple causes for "Submit for review" symptom, like full DB, broken DB table, etc. .... user(site admin) is lost.

Change History (1)

comment:1 @nacin5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

It's actually 20. Duplicate of #13709, fixed in 3.1. Of course, correct answer is, don't do that :-)

Note: See TracTickets for help on using tickets.