WordPress.org

Make WordPress Core

Opened 5 years ago

Last modified 3 years ago

#16445 new defect (bug)

Don't allow imported IDs to be greater than 2^31 — at Version 2

Reported by: Viper007Bond Owned by:
Milestone: Future Release Priority: normal
Severity: normal Version: 3.1
Component: Import Keywords:
Focuses: Cc:

Description (last modified by Viper007Bond)

For various reasons, things go bad when you get a post ID greater than 231. When we're importing content and there's an existing ID, I suggest we ignore it if possible if it's too big.

Tumblr2WordPress for example maintains the Tumblr IDs and causes problems in WordPress.

Change History (2)

comment:1 @Viper007Bond5 years ago

  • Description modified (diff)

comment:2 @Viper007Bond5 years ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.