WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16452 closed enhancement (duplicate)

Remove 'Settings' > 'General' > 'WordPress address (URL)' and 'Site address (URL)' from backend

Reported by: jottlieb Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Administration Keywords:
Focuses: Cc:

Description

As I'm maintaing the German WordPress Forums, I notice that many people unintentionally bring their WordPress installs to standstill, because they're editing the input fields 'WordPress address (URL)' and/or 'Site address (URL)' by curiosity.

The're are only few scenarios, why these input fields might be useful. In most cases they produce damage.

So I propose to remove the fields (why don't edit wp-config.php instead?) or at least put a big warning message next to them. Another suggestion is to show a JS alert after editing ('...Only change this, if you know what you're doing...only enter an URL, that physically points to your Blog...').

Change History (4)

comment:1 @nacin5 years ago

I mostly agree, but this is a duplicate of a few other tickets.

comment:2 @nacin5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Found it, #10970.

comment:3 @jottlieb5 years ago

Sorry for the inconveniences, my search in trac did not find anything.

comment:4 @nacin5 years ago

Not a problem, I knew exactly what I was looking for and it still took me a few minutes. :-)

Note: See TracTickets for help on using tickets.