WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16453 closed defect (bug) (invalid)

images with .jpeg extension are not resized (.jpg works)

Reported by: dwenaus Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

images with the .jpeg extension that are missing filetype data are not resized using wp image resize functions

Change History (4)

comment:1 dwenaus3 years ago

for example, if you have an image that is missing filedata that is called image.jpeg it will not be resized with the_post_thumbnail(). however change the name of that image to image.jpg and it will work.

images with proper filedata named .jpeg do get resized.

comment:2 kawauso3 years ago

  • Keywords reporter-feedback added

Couldn't reproduce this with a JPEG stripped of header data with jhead's -purejpg flag and a Windows Xampp install with GD installed.

Can you attach an example image to reproduce with? Found #16458 while looking at this and is possibly related.

comment:3 dwenaus3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

i tried to replicate it again, on a different server, and had no luck, so close this i guess.

comment:4 ocean903 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.