WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 3 months ago

#16494 closed enhancement

Remove "no conflict" mode from bundled jquery — at Initial Version

Reported by: lloydbudd Owned by:
Milestone: Priority: low
Severity: minor Version: 3.1
Component: External Libraries Keywords: has-patch
Focuses: Cc:

Description

Remove "no conflict" mode from jquery

Over the last six months more and more of the themes I review for large sites have being using Google's CDN version of jquery (deregistering the bundled), not to get the benefit of CDN, but because many jquery libraries and don't know or wan to deal with dealing with getting them to work in "no conflict".

I image we originally put in place "no conflict" mode for bundled jquery, as part of the transition from Prototype.

I appreciate it is hard to measure the impact of this type of change, but wanted to trac this all the same.

Additional Info

http://codex.wordpress.org/Function_Reference/wp_enqueue_script#jQuery_noConflict_wrappers

http://docs.jquery.com/Using_jQuery_with_Other_Libraries

Change History (0)

Note: See TracTickets for help on using tickets.