Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#16508 closed defect (bug) (fixed)

Widgets are completely frozen in the back end. Widget usability is 0% with no possibility of editing...

Reported by: trusktr Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.5
Component: Widgets Keywords:
Focuses: Cc:


My widgets in the back end are completely frozen, along with other UI features. For example, i can't drag any draggable UI elements (most impartantly widget) and I can't expand or collapse any expandable/collapsable elements (most importantly widgets). I have the latest version of wordpress; freshly upgraded. I've also deactivated ALL plugins, but that doesn't fix the problem.

So basically, my main priority is to edit my widgets, but i can't expand them with the down arrow to edit their settings. I can't drag them to re-arrange them or delete them. I can't do anything with them!!!

The major problem is that I want to upgrade one of my plugins that provides widgets, but if I upgrade the plugin, I'll have to re-do the settings of the widgets since they have been re-designed. However, I will not be able to do any editing and will therefore be stuck with blank, non-working widgets.

If in the future i decide to add/remove widgets, it's completely impossible.

Well, i'm sure it's possible if I dig around through the database and make manual modifications, but that defeats the purpose of the graphical back end.

I've also tried various browsers and they all have the same problem.

I'm not the only one experiencing this issue, it is popping up in multiple instances across the forums. Here's a post I made about it:

I hope this can be fixed so I can resume normal use of my blog!

THanks in advance to those who may know how to squash this bug. :)

Attachments (1)

restore-bundled-jquery.php (887 bytes) - added by SergeyBiryukov 5 years ago.
Restores and enforces the bundled jQuery in the admin.

Download all attachments as: .zip

Change History (25)

comment:1 @ryan5 years ago

Are there any JS errors in the console?

I can't reproduce this, and 3.0.5 changed nothing related to this. Very odd. Diffs from 3.0.4 to 3.0.5 don't show any obvious culprits. http://core.trac.wordpress.org/changeset?old_path=/tags/3.0.4&old=17436&new_path=/tags/3.0.5&new=17436

Are you definitely on 3.0.5? Not accidentally upgraded to 3.1?

comment:2 @AlexLakes5 years ago

You might try disabling js concatenation in wp-config. I ran into an issue with a particular theme a while back and adding this to my wp-config fixed the JS issue. Worth trying.

define('CONCATENATE_SCRIPTS', false);

comment:3 @AlexLakes5 years ago

Whoa. He's right. I have the same issue too. Turning off concantenation of scripts didn't solve it. I also cannot drag, drop, or edit widgets. Also, if I'm editing a published post and try to change the slug, #post_name is added to the url in the browser but nothing happens. Same is true clicking 'Edit' for the post status, visibility and published time too. So it must to be some type of javascript error.

WP 3.0.5, subfolder installation in case that matters

comment:4 follow-up: @AlexLakes5 years ago

I think I may have found the issue. In the admin area, the following url returns nothing (a blank page).


comment:5 @westi5 years ago

What host are you on?
What do you see in the php error log - anything?

comment:6 in reply to: ↑ 4 @dd325 years ago

Replying to AlexLakes:

I think I may have found the issue. In the admin area, the following url returns nothing (a blank page).


Just to quickly check, Accessing that url will return nothing on all hosts. That's because '&' is only valid in HTML, when typed into a browser it'll need to be changed to just '&':


comment:7 @jorbin5 years ago

  • Keywords reporter-feedback added; widgets javascript removed

is your theme enqueue ing a different version of jquery or any of the jquery plugins?

comment:8 @jorbin5 years ago

  • Component changed from UI to Widgets

comment:9 @Denis-de-Bernardy5 years ago

Are you using a modern browser?

And... how many widgets are you using, and which ones... and which plugins that affect widgets?

Reason I'm asking is #10021.

comment:10 @AlexLakes5 years ago

& > & Color me embarassed on that one!

I found my issue. Not sure if the OP has. Mine was user error. I made a coding error when I deregistered jquery-ui-sortable to enqueue it only on a given page on the front end and also in the admin area. But then I enqueue'd the wrong script, jquery-ui, instead of jquery-ui-sortable. Sorry all for mine.

@OP I'd check if your issue is related to jquery-ui-sortable.

comment:11 @nacin5 years ago

  • Severity changed from blocker to normal

That's a bit more edge than what I was thinking. jorbin proposed what I thought would be the likely the issue: A theme is enqueueing jQuery 1.5. But, I just tested jQuery 1.5 on trunk (very lightly) and the widgets screen worked just fine.

comment:12 @westi5 years ago

This whole ticket reads like it should have been a support forum thread until a clear bug was identified.

comment:13 @markjaquith5 years ago

With script debug turned off, this breaks Widgets:

function jquery15( $src ) {
	$src = preg_replace( '#^(.*)/jquery.js(.*)$#', 'https://ajax.googleapis.com/ajax/libs/jquery/1.5.0/jquery.min.js', $src );
	return $src;

add_filter( 'script_loader_src', 'jquery15' );

It looks like in that case, jQuery is enqueued AFTER jQuery UI, which obviously doesn't work.

@SergeyBiryukov5 years ago

Restores and enforces the bundled jQuery in the admin.

comment:15 @SergeyBiryukov5 years ago

Wrote a plugin to restore the bundled jQuery in the admin (as per suggestion in the post).

comment:16 follow-up: @filosofo5 years ago

The issue is addressed and fixed here on trunk jQuery: http://bugs.jquery.com/ticket/8123

It's not obvious from the jQuery ticket what the bug is, but this UI ticket has a clearer explanation: http://bugs.jqueryui.com/ticket/6955

comment:17 in reply to: ↑ 16 @filosofo5 years ago

Replying to filosofo:

It's not obvious from the jQuery ticket what the bug is

I mean that it's not obvious how the bug pertains to the draggable error issue here.

comment:18 @SergeyBiryukov5 years ago

  • Keywords reporter-feedback removed

comment:19 @trusktr5 years ago

Hey guys, so mine works now. I haven't changed anything except i cleared my browser cache in Chrome... but this still doesn't explain why it wasn't working in other browsers. Today i turned my computer on, and it just worked... What the???

Anyways, when i had 3.0.4, i had downgraded jquery (but i do believe widgets were working), then put back the wordpress jquery later. I refreshed my browsers, and the effects of replacing jquery would show up on my front-end. However, the backend had this problem no matter what version of jquery i tried (as far back as jquery.1.2.6), even the latest.

But i did indeed notice that the backend uses a php file to load scripts (load-scripts.php?) so perhaps this was having some sort of problem with the files?? Does that script check md5 sums or something along those lines??

Anyways, perhaps that plugin SergeyBiryukov made above would have helped. Sorry i can't really help find what the problem was. I wish I knew so you guys (the true programmers) could figure out how to fix it.

If it happens again, i'll definitely post back.

comment:20 @trusktr5 years ago

As noted by Andrew, jquery 1.5 s the culprit... but i have 1.5 despite my backend working all of a sudden...

comment:21 follow-ups: @filosofo5 years ago

jQuery 1.5. has been released, including a fix for this issue.

Version 0, edited 5 years ago by filosofo (next)

comment:22 in reply to: ↑ 21 @ramoonus5 years ago

Replying to filosofo:

jQuery 1.5.1 has been released, including a fix for this issue.

see #16426

comment:23 in reply to: ↑ 21 @SergeyBiryukov4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

comment:24 @SergeyBiryukov4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.