WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 9 months ago

#16519 closed defect (bug) (duplicate)

pingback url is right-trimmed incorrectly

Reported by: qdinar Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Pings/Trackbacks Keywords:
Focuses: Cc:

Description

an url ending with %d0%b5%d1%81% was produced by pingback mechanism, that url is in pingback comment, and server returns for its request:
Bad Request
Your browser sent a request that this server could not understand.


but if it would end with %d1%81 it works. wordpress automatically fixes it. but also it does not open if it ends with %d1%8 or %d1 .

Change History (3)

comment:1 nacin3 years ago

  • Version set to 3.0

comment:2 nacin3 years ago

  • Component changed from General to Pings/Trackbacks

comment:3 dd329 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

If i'm understanding this correctly, It sounds like that the comment_author_url field was too short for the long pingback URL provided (since the URL length was increased by encoded characters), and thus it was truncated, resulting in an invalid URL.

I'm closing as a duplicate of the more well explained #17771

Note: See TracTickets for help on using tickets.