WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 18 months ago

#16520 closed defect (bug) (worksforme)

When selecting more than 10 plugins to up date Update not working

Reported by: cCat5564 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.5
Component: Upgrade/Install Keywords: reporter-feedback
Focuses: Cc:

Description

When i am trying to update more than 10 plugins, Updater clams that it updated the plugins, but when clicking 'Return to WordPress Updates' i see the "Updated" plugins

Attachments (1)

wp-plugin-update-problem.jpg (227.2 KB) - added by cCat5564 3 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 cCat55643 years ago

see screenshot about this

comment:2 dd323 years ago

  • Component changed from Plugins to Upgrade/Install
  • Keywords reporter-feedback added

Havn't attempted to confirm this yet, It seems rather... unlikely.

That sort of output basically means that the upgrader has been passed either

  • an empty list of plugins
  • none of the plugins actually exist (although, I think that throws an error message)

If it's an empty list of plugins, that could be caused by a browser issue, or possibly a server limit being applied (but that seems like a rather low limit).

cCat5564: What browser are you using? Did you try with 9 plugins? Are you using the FTP or Direct updates (ie. did it ask for FTP credentials?)

comment:3 cCat55643 years ago

LunaScape (it was Firefox), Direct update, it doesn't ask, when i use 5 or 8 plugins it updates, 27 plugins -> will not update, empty list, (i know that there is no limit, browser is fine)

Last edited 3 years ago by cCat5564 (previous) (diff)

comment:4 BrandiBoyd3 years ago

I am having this same issue on a multi-Site enabled WordPress that has very little content but lots of plugins, and is mainly for testing purposes right now. It has one main site and a second subdomain site. Doesn't matter how many plugins I select or upgrade. I have tried all (an embarrassing amount- 40- I've been bad), just one, three, 8, and 12. The results are the same. During the auto upgrade process each plugin displays it's "updated successfully" bit, the page displays that all updates have been completed, and then when I return to the updates or the plugins page, the newly updated plugins still show the notification balloons in menus and are still in the 'needs updates' list. Once my next try completes I can post screenshots.

comment:5 dd323 years ago

Confirmed that >15 plugin updates does infact work correctly.

This sounds like mod_security or suhosin is kicking in.

For example suhosin.post.max_array_index_length limits the number of array items which can be posted (defaults to 64, but might be set low?). There's another 2 fields which can affect it too: suhosin.post.max_vars and suhosin.request.max_vars

Another example of this is #14134

Do the posters here have a phpinfo() output of their configurations? (feel free to contact me off-trac with those: wordpress @ dd32.id.au)

comment:6 follow-up: dd323 years ago

unfortunately, even if that is the cause, I unfortunately can't see anything that WordPress itself can do about this, It's a server configuration issue. We can probably close this ticket if it turns out to be caused by either of those simply due to the environment..

..Another thought, is what Browser is in use? does it happen in all browsers?

comment:7 in reply to: ↑ 6 strider723 years ago

Replying to dd32:

I unfortunately can't see anything that WordPress itself can do about this, It's a server configuration issue.

Is it possible for WordPress to figure out that there's a problem, so at the least it can give a useful error message instead of a false "Success"?

comment:8 dd323 years ago

It should be bailing with a message along the lines of "Sorry, nothing was selected" or redirecting you back to the updates page.. As as far as WordPress will be able to tell, thats exactly what would've happened..

I do agree, the bulk upgrader shouldn't be displaying the way it does provided no input.

The "Success" message is, in many ways true, It's succeeded in completing the tasks provided (None!). See also: #16817 - Success is shown when an individual upgrade failed, it's not refering to the overall success of the items, rather the success of itself in the script not timing out - that needs to change.

comment:9 dd3218 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.