Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#16532 closed defect (bug) (fixed)

Network Admin update bubbles should check permissions

Reported by: nacin Owned by: ryan
Milestone: 3.2 Priority: low
Severity: minor Version: 3.1
Component: Network Admin Keywords: 3.2-early has-patch
Focuses: multisite Cc:


It's not uncommon especially in a multisite install for various update capabilities to be denied. We should suppress the bubbles in this case, considering the pages don't show any information once visited, as those are cap-checked.

Attachments (2)

16532.diff (6.2 KB) - added by nacin 5 years ago.
16532.2.diff (10.0 KB) - added by ryan 5 years ago.
For wp-admin/menu.php too

Download all attachments as: .zip

Change History (8)

5 years ago

#1 @garyc40
5 years ago

Related, possibly duplicated? #14447

#2 @nacin
5 years ago

That's for the non-network admin. Both should be applied.

#3 @nacin
5 years ago

  • Keywords 3.2-early has-patch added
  • Milestone changed from Awaiting Review to Future Release

#4 @nacin
5 years ago

  • Milestone changed from Future Release to 3.2

5 years ago

For wp-admin/menu.php too

#5 @ryan
5 years ago

Patch avoids doing update checks in menu.php and calculating the plugin count twice.

#6 @ryan
5 years ago

  • Owner set to ryan
  • Resolution set to fixed
  • Status changed from new to closed

In [17822]:

Don't fetch update info our show update bubbles if the user does not have install caps. Props nacin. fixes #16532

Note: See TracTickets for help on using tickets.