WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#16534 closed defect (bug) (wontfix)

swfuploader IO error

Reported by: funkimunky Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Media Keywords:
Focuses: Cc:

Description

I get an IO error when uploading using SWFUploader.
This might be related to this ticket (http://core.trac.wordpress.org/ticket/14648) but I am not sure so I opened another

I am using local windows installation of wordpress in ZEND apache2 setting.
I have set up windows host file to forward domain to localhost 127.0.0.1
127.0.0.1 mydomain.local

I have set up apache vhost.conf

<VirtualHost *:80>
ServerAdmin myemail@…
DocumentRoot "D:/apachewww/mydomain/html"
ServerName mydomain.local
ErrorLog D:/apachewww/mydomain/log/mydomain.error.log
CustomLog D:/apachewww/mydomain/log/mydomain.access.log common
</VirtualHost>

<Directory "D:/apachewww/mydomain/html">
Options -Indexes FollowSymLinks
AllowOverride AuthConfig FileInfo
Order allow,deny
Allow from all
</Directory>

I have set up firefox to bypass proxy server for
127.0.0.0/24,local,localhost,stuff

this works fine for .local domain
I can create a site the upload using swfuploader with no problems

Now if I choose to use domain

mydomain.stuff

cleaning out the database and files then creating a new site.
updating the vhosts.conf to reflect this and the windows hosts file
I can browse and create a site
but now if I try and upload images using swfuploaded I get an IO error
It seems to be something specifically to do with domain names.

I have created a crossdomain.xml file and placed this in the root of my sites directory (this should be the only site that SWFUploader is trying to access)

<?xml version="1.0"?>
<!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">

<cross-domain-policy>

<allow-access-from domain="mydomain.stuff" />

<allow-access-from domain="*.mydomain.stuff" />
<allow-access-from domain="*.stuff" />

<allow-access-from domain="127.0.0.1" />

<allow-access-from domain="stuff" />

</cross-domain-policy>

This does not fix the issue.

Change History (1)

comment:1 ocean903 years ago

  • Keywords SWFUploader IO Error removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

WordPress is now using Plupload. Plupload uses HTML5 first and should fall back to flash only in IE if silverlight is not installed.

Please test if you still have issues with the media uploader in trunk.

See #18206 for the new file uploader.

Note: See TracTickets for help on using tickets.