WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#16535 closed defect (bug) (worksforme)

Strings in internal linking not displayed

Reported by: pavelevap Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: I18N Keywords:
Focuses: Cc:

Description

  • Select word in visual editor and click link button
  • New window for new internal linking appears
  • "Add New" at the bottom remains in English ("Update" also when editing link) even if translated.

Change History (5)

comment:1 @nacin5 years ago

These get translated via the script loader. Check the source of the HTML page, you should see the translated strings when you look for 'wpLinkL10n'.

comment:2 @pavelevap5 years ago

Yes:

var wpLinkL10n = {
	update: "Update",
	save: "Add Link",
	noTitle: "(no title)",
	noMatchesFound: "No matches found."
};

But there should be translated strings and not English originals?

comment:3 @SergeyBiryukov5 years ago

Can't reproduce on 3.1-RC4-17441. Potentially can be caused by a plugin, like in #11526.

comment:4 @pavelevap5 years ago

Yes, sorry for bothering you.

I tested today latest version of WP e-Commerce (http://svn.wp-plugins.org/wp-e-commerce/branches/3.8-development) and after deactivating this problem disappeared...

And I forgot to deactivate it and did not realize that can be caused by plugin...

comment:5 @ocean905 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

No problem.
So closing it as worksforme with a hint too #11526.

Note: See TracTickets for help on using tickets.