WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#16536 closed defect (bug) (fixed)

Plugins page table layout seems skewed

Reported by: donalmacarthur Owned by:
Milestone: 3.1 Priority: normal
Severity: trivial Version: 3.1
Component: Administration Keywords: has-patch needs-testing
Focuses: Cc:

Description

On the Plugins page, the table layout seems to be a little skewed. Comparing 3.05 and 3.1-RC-4, the 'Plugins' column in the release candidate version is significantly wider - maybe 40% of the total table width. I first noticed this in 3.1-RC-3 - I'm not sure if it goes back any further.

Anyway, it's just a styling issue, but there's a lot of empty space there, especially if you're viewing the dashboard on a wide screen. I presume this isn't an intentional change, but if it is, it isn't scaling very attractively at wider resolutions.

I've taken a look in the latest versions of Chrome and Firefox, plus IE8, and the page is displaying identically in all of them, so it isn't a browser issue.

Attachments (4)

16536.diff (1.8 KB) - added by garyc40 5 years ago.
fix plugin and theme title width in WP_Plugins_List_Table and WP_MS_Themes_List_Table
plugin-list-after.png (63.4 KB) - added by garyc40 5 years ago.
theme-list-after.png (28.7 KB) - added by garyc40 5 years ago.
Screen shot 2011-02-14 at 12.01.42 PM.png (213.4 KB) - added by garyc40 5 years ago.
how it looks with lots of action links and small window size

Download all attachments as: .zip

Change History (16)

comment:1 @ocean905 years ago

A screenshot would be nice.

comment:2 @nacin5 years ago

  • Component changed from General to Administration
  • Keywords needs-patch added

Confirmed. 3.0: http://cl.ly/3I052K3L2a3O2e2B250v. 3.1: http://cl.ly/3C172f253r1930060A2q.

It does seem like a waste of space. With a patch, we can probably squeeze it into 3.1 or ship it with 3.1.1.

I spy an unrelated string regression. #16543

@garyc405 years ago

fix plugin and theme title width in WP_Plugins_List_Table and WP_MS_Themes_List_Table

comment:3 @garyc405 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

Attached patch restores the css for plugin title and theme title's width in WP_Plugins_List_Table and WP_MS_Themes_List_Table. The width now depends on the size of the content of the table cell.

@garyc405 years ago

@garyc405 years ago

comment:4 @nacin5 years ago

We'll need to blame this code. I specifically remember nowrap being pulled, and I wonder where the 60% came from.

comment:6 @SergeyBiryukov5 years ago

nowrap was pulled in [17116].

comment:7 @nacin5 years ago

nowrap was pulled for very specific reasons, #15834. We need to make sure the same bug doesn't return.

comment:8 @nacin5 years ago

Not saying this isn't a good fix, either. The plugins table looks pretty lame on most resolutions.

comment:9 @garyc405 years ago

16536.diff passes scribu's test case in #15834.

I guess the reason why nowrap failed in #15834 was because plugin list table is table-layout:fixed, so nowrap breaks it. The fix should have been removing .fixed class for plugin list table instead.

comment:10 @nacin5 years ago

  • Milestone changed from Awaiting Review to 3.1

Huh, nice catch. I didn't know that's what .fixed did for us.

@garyc405 years ago

how it looks with lots of action links and small window size

comment:11 @ryan5 years ago

Drive by note: Is /wp-admin/network/site-themes.php getting the new styling? During my brief look it still seemed to have the extra spacing. I'll look closer later. Other than that maybe non-issue it looks much better with the patch.

comment:12 @ryan5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

[17449] for trunk and [17450] for 3.1.

Note: See TracTickets for help on using tickets.