Make WordPress Core

Changes between Version 1 and Version 2 of Ticket #16539, comment 63


Ignore:
Timestamp:
04/04/2013 11:46:58 PM (11 years ago)
Author:
bpetty
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #16539, comment 63

    v1 v2  
    44The id is already removed in the HTML5 version committed to SVN.
    55
    6 The HTML4 version in the patch chooses to use duplicate IDs, as opposed to incrementing (dynamically changing) IDs for the purpose of not breaking compat with themes/plugins (since it was using the same duplicated ID in 3.5 and below) - see ticket:23868#comment:7. Basically it reverts the changes made earlier in this ticket to the HTML4 version so it behaves like it did in 3.5 and below. If Jaws wasn't broken in 3.5, it shouldn't be with 16539.10.diff.
     6The HTML4 version in the patch chooses to use duplicate IDs, as opposed to incrementing (dynamically changing) IDs for the purpose of not breaking compat with themes/plugins (since it was using the same duplicated ID in 3.5 and below) - see ticket:23868#comment:4. Basically it reverts the changes made earlier in this ticket to the HTML4 version so it behaves like it did in 3.5 and below. If Jaws wasn't broken in 3.5, it shouldn't be with 16539.10.diff.
    77
    88So, from what I gather here, older Jaws should be fine with the HTML4 version in 16539.10.diff, and if theme designers care to remain compat with older Jaws, they will probably stick with writing HTML4 anyway rather than opting for the HTML5 version.