WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 22 months ago

#16566 closed defect (bug) (duplicate)

Copyright symbol not transformed in post slug

Reported by: Coolkevman Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Permalinks Keywords: 3.2-early has-patch
Focuses: Cc:

Description

When you use an ASCII copyright symbol within a post title, the generated slug keep the copyright symbol. See a screenshot of my test case here: http://twitpic.com/4058mz

For reference, here is the title string (I hope Trac will not mess the encoding):

New forum © by someone

To me this looks like a bug as slugs are here to increase "search engine friendliness" of WordPress.

Some solutions may be:

  • To strip the copyright symbol out of the
  • Replace the symbol by a single c letter
  • Replace the symbol by another word like (c), copyright, ...

This bug was produced on a fresh WordPress 3.1-RC4 instance.

Attachments (1)

16566.diff (448 bytes) - added by greuben 3 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Coolkevman3 years ago

I was wrong, the copyright symbol in my string is not an ASCII one. Here is the proof:

$ python
Python 2.6.6 (r266:84292, Sep 15 2010, 16:22:56)
>>> t = "New forum © by someone"
>>> for x in t:
...   print "%s -> %s" % (ord(x), x)
...
78 -> N
101 -> e
119 -> w
32 ->
102 -> f
111 -> o
114 -> r
117 -> u
109 -> m
32 ->
194 -> �
169 -> �
32 ->
98 -> b
121 -> y
32 ->
115 -> s
111 -> o
109 -> m
101 -> e
111 -> o
110 -> n
101 -> e
>>>

This bug report is still valid as the slug sanitization process doesn't ends with a clean URL.

greuben3 years ago

comment:2 greuben3 years ago

added an attachment it removes copyright and registered symbol in remove_accents()

comment:3 nacin3 years ago

  • Keywords 3.2-early added
  • Milestone changed from Awaiting Review to Future Release

This needs to be done in conjunction with rolling permalink updates, as otherwise this will break existing links.

comment:4 edwardw3 years ago

  • Keywords has-patch added

comment:5 SergeyBiryukov22 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12956. Fixed in [18705].

Note: See TracTickets for help on using tickets.