WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#16569 closed defect (bug) (fixed)

adding a link to an image through tinymce's button is broken if align is set

Reported by: mimecine Owned by: azaozz
Milestone: 3.4 Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Very peculiar bug. If I try to link an image wth tinymce's link button, I can only do it if there is no align set or set to alignnone it seems.

  • Just tried a bit more and it seems to be a webkit bug. It only occurs in Safari and Chrome (Safari being the latest release, and Chrome the latest Dev-channel release).

Will try to log a bug with TinyMCE, but wanted it recorded here in case anyone else have the same problems.

Change History (5)

comment:1 follow-up: linuxologos2 years ago

  • Keywords needs-patch added; tinymce images links removed
  • Version 3.1 deleted

Closed #19468 as duplicate.

Using latest Chrome, it seems that this bug goes way back (I can reproduce till 2.8 at least). Until 3.0 only center-aligned images were affected. From 3.1 on, all alignments reproduce this bug.

comment:2 in reply to: ↑ 1 azaozz2 years ago

Seems to be our "wplink" MCE plugin that's doing it, works as expected when using the build-in MCE link popup.

comment:3 SergeyBiryukov2 years ago

Closed #20343 as a duplicate.

comment:4 azaozz2 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [20341]:

Editor: fix adding a link in WebKit to floated image, fixes #16569

comment:5 helenyhou2 years ago

  • Keywords needs-patch removed
  • Milestone changed from Awaiting Review to 3.4
Note: See TracTickets for help on using tickets.