Make WordPress Core

Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#16578 closed enhancement (duplicate)

TinyMCE plugins are not loaded as .dev.js when SCRIPT_DEBUG is enabled

Reported by: solarissmoke Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description

In trunk, when SCRIPT_DEBUG is enabled, TinyMCE does not load plugins using .dev.js scripts. It would be nice if it did.

Change History (5)

#1 @kawauso
11 years ago

All the instances in core of TinyMCE plugin loading I could find use the $suffix variable, which add .dev as necessary. Couldn't reproduce on my trunk install either.

http://core.trac.wordpress.org/browser/trunk/wp-includes/script-loader.php#L268

#2 @solarissmoke
11 years ago

No, there are only a couple of TinyMCE plugins loaded using script-loader.php, and that's because they have dependencies. The rest are loaded differently, and that's where the issue it.

Try any of the other TinyMCE plugins: wpeditimage, wordpress, inlinepopups, spellchecker, tabfocus etc.

#3 @iseulde
8 years ago

  • Component changed from General to TinyMCE

#4 @azaozz
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to fixed
  • Status changed from new to closed

This was fixed some time ago. TinyMCE 3.x uses different naming: editor_plugin.js is the minified version, editor_plugin_src.js in the dev. version.

#5 @duck_
8 years ago

  • Resolution changed from fixed to duplicate
Note: See TracTickets for help on using tickets.