WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#16649 closed defect (bug) (duplicate)

Custom Post Names Can not include capital letters

Reported by: rfrankel Owned by:
Milestone: Priority: normal
Severity: critical Version: 3.1
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

After upgrading to WP3.1 I noticed none of my custom taxonomies worked with my custom post type. I have been able to figure out what is going on an it has to do with a custom post type being registered with a capital letter in its name. I.e. (set up code removed for clarity):

Will WORK:
register_post_type('posttypename', $args);
register_taxonomy( 'milestone', 'posttypename', $args );

Will Not Work:
register_post_type('postTypeName', $args);
register_taxonomy( 'milestone', 'postTypeName', $args );

I am not sure if this is by design or a bug but it has worked fine up until 3.1.

This is my first bug report so hopefully I haven't made an a of myself.

Change History (2)

#1 @greuben
10 years ago

  • Keywords needs-patch removed
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #16600

#2 @ocean90
10 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.