WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#16716 closed defect (bug) (duplicate)

Page Screen Options: Number of Columns Not Switching Correctly to 2

Reported by: depi Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Administration Keywords: ui-feedback needs-patch
Focuses: Cc:

Description

This bug occurs when you are editing a Page and you setup a number of columns to 1 in the Screen Options and then change this setting back to 2. It remains fixed on 1.

Change History (4)

comment:1 @nacin4 years ago

Works for me. Once you hide a column, it will be blank upon showing it again. You'll need to move the various meta boxes that started in column 2, back to column 2.

Doubtful, but if the option is literally sticking, could this be a javascript error caused by a plugin?

comment:2 @depi4 years ago

Yes, that's right. However I think it should go back to its previous position. Also is it quite hard to put it back, is is hard to get that area for stick to appear.

comment:3 @andrewryno4 years ago

In order for it to go back to the way you had it before the switch, we would have to store each previous position in the database. There should be no reason to do that. Once it changes, it's saved for good and you'll have to change it back manually. Unless we possibly put in a "Reset" option and only store the default positioning?

comment:4 @duck_4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate: #16493, #13476, #14423

Note: See TracTickets for help on using tickets.