WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16720 closed defect (bug) (fixed)

Network Admin - Site Search breaks Row Action Links

Reported by: Ipstenu Owned by:
Milestone: 3.1.1 Priority: normal
Severity: major Version:
Component: Multisite Keywords: has-patch commit
Focuses: Cc:

Description

http://blog.dearbornschools.org/webmaster/files/2011/03/networkadmin_issue.swf

Basically.

If you go to wp-admin/network/sites.php and try to mark a site as spam or anything on the hover-over links, it's fine.

BUT if you SEARCH for a site, it CHANGES those row action links from

/wp-admin/network/edit.php?action=confirm&action2=spamblog&id=11......

to

/SEARCHVALUE/wp-admin/network/edit.php?action=confirm&action2=spamblog&id=11......

Which blows up in your face.

Worse is if you use a wildcard, then you get SEARCHVALUE% as the URL.

Here's the best part. It only happens on subFOLDER multisite. Works perfectly fine on subdomain.

I was able to reproduce it on two separate subfolder installs, one with no plugins at all.

Attachments (1)

16720.diff (644 bytes) - added by greuben 3 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Ipstenu3 years ago

Forum post wherein we sorted this out: http://wordpress.org/support/topic/network-admin-user-and-site-admin-links-dont-work-31

(I can't repro the user issues he had, but I can the blog search)

comment:2 firmdot3 years ago

I'm having same/similar issue.

I go to Network Admin, Search sites. Search for a site with a wildcard i.e. photo* the results show up just fine, HOWEVER after clicking on any of the site options for the found site (i.e. Edit, Spam, Archive, Delete) the URL changes to:

www.mydomain.com/photo%/wp-admin/network/site-info.php?id=32

comment:3 nacin3 years ago

  • Milestone changed from Awaiting Review to 3.1.1

comment:4 nerx3 years ago

  • Cc nerx added
  • Keywords needs-patch added
  • Severity changed from normal to major

Tested with Subdomain from [1und1.de] Result: Same as subFOLDER!

greuben3 years ago

comment:5 greuben3 years ago

  • Keywords has-patch added; needs-patch removed

see patch!

comment:6 Ipstenu3 years ago

Patch works for me on subfolders (cannot repro on subdomains like nerx can, but it doesn't BREAK anythign I can see).

comment:7 greuben3 years ago

That part of code is only executed for directory installs so I am sure subdomain installs will not have this problem.

comment:8 nacin3 years ago

  • Keywords commit added

Typo introduced in [16161].

comment:9 nacin3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [17496]) Avoid mangling the current site path variable with the search query. props greuben, fixes #16720 for trunk.

comment:10 nacin3 years ago

(In [17497]) Avoid mangling the current site path variable with the search query. props greuben, fixes #16720 for the 3.1 branch.

comment:11 follow-up: tmoorewp3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Edit: Nevermind, I think I read Trac wrong. This patch will be out with 3.1.1?

This patch didn't make it into the 3.1 download on wordpress.org. I've got two MultiSite installations running upgraded 3.1 installations and this bug is still present. When I upgraded, I manually deleted the entire wp-admin folder and replaced it with the new copy from the wordpress.org download. If I apply this patch, they work fine.

Last edited 3 years ago by tmoorewp (previous) (diff)

comment:12 tmoorewp3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:13 in reply to: ↑ 11 ocean903 years ago

Replying to tmoorewp:

This patch will be out with 3.1.1?

Yes. :)

Note: See TracTickets for help on using tickets.