Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#16732 closed defect (bug) (invalid)

media_upload_tabs filter not called for non-async upload

Reported by: leewillis77 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Media Keywords:
Focuses: Cc:


Steps to reproduce:

  • Register a custom post type (The media uploader only seems to show tabs on non-"post" post types???)
  • Add a simple filter to media_upload_tabs (See attached)
  • Click to create a new post of your post type
  • Click to upload/insert an image using the "add an image" link
  • Note that the media uploader does not have a gallery tab (Screenshot 1)
  • Switch to "Browser Uploader" rather than flash
  • Browse for a file, and upload
  • The media uploader is re-loaded, but this time the Gallery tab shows. (Screenshot 2). media_upload_tabs is not being called.

Uploading media using the flash uploader doesn't have this problem (Probably because the media upload is carried out via an in-page ajax replacement rather than reloading the whole uploader.)

Attachments (3)

filter.php (125 bytes) - added by leewillis77 5 years ago.
Example filter
Screenshot-1.png (23.3 KB) - added by leewillis77 5 years ago.
Screenshot 1
Screenshot-2.png (72.9 KB) - added by leewillis77 5 years ago.
Screenshot 2

Download all attachments as: .zip

Change History (6)

5 years ago

Example filter

5 years ago

Screenshot 1

5 years ago

Screenshot 2

#1 @leewillis77
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

#2 @leewillis77
5 years ago

Ignore me - not a bug...

#3 @duck_
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.