Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#16737 closed defect (bug) (invalid)

prototype 1.6.1 in WP3.1 broken in IE6-8

Reported by: mpol Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: External Libraries Keywords:
Focuses: Cc:


Prototype.js is broken in Wordpress 3.1.0 when used in IE6 to IE8. It gives a script error on line 4821:

var nodes = $(element).getElementsByTagName('*');

The error is that this method is not supported by this object.
I changed that line to:

var nodes = element.getElementsByTagName('*');

And now it runs fine in IE6-IE8

I'm definitely no guru with javascript, so I'm not sure if this is the preferred fix.
I also tried using prototype-1.7, but that gave the same error.

Change History (1)

#1 @scribu
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Since WP itself doesn't use prototype.js at all any more, this error is likely caused by some other code (from a plugin or theme) that's using it wrong.

Feel free to re-open this ticket if you can prove that the cause is some change made since WP 3.0. (You can leave comments while the ticket is closed, in the mean time)

Note: See TracTickets for help on using tickets.