WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 11 months ago

#16779 closed enhancement (fixed)

Ignore capitalization during login

Reported by: bandonrandon Owned by:
Milestone: WordPress.org Priority: normal
Severity: minor Version:
Component: WordPress.org site Keywords:
Focuses: Cc:

Description

The login box at wp.org seems to be case sensitive. In my case if I type "bandonrandon" it returns with "user not registered" but if I type "BandonRandon" I am able to login. However, it seems that "bandonrandon" is also connected to my account and isn't available for registration.

My thoughts on this are to maybe ignore the case of the user when they login to the site. The same can be said for plugins. If my name is "bandonrandon" in the plugin readme my gravatar is not shown but if it's "BandonRandon" my gravatar is shown.

Change History (4)

comment:1 mikeschinkel3 years ago

  • Cc mikeschinkel@… added

This would certainly be an improvement to keep dumbfounded users from being locked out of their site simply because they didn't remember they used mixed case, or not.

Wondering if there is a valid reason why this would cause a legacy issue?

comment:2 solarissmoke3 years ago

@mikeschinkel the issue is for wordpress.org. Login on Wordpress itself is case-insensitive.

comment:3 SergeyBiryukov3 years ago

  • Milestone changed from Awaiting Review to WordPress.org

comment:4 Otto4211 months ago

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed by now, however it may not be fixed in all places. If you find an individual place where login is still case-sensitive, bring it up as a new ticket on meta.trac.

Note: See TracTickets for help on using tickets.