WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 6 years ago

#16787 closed defect (bug) (fixed)

Removing title from a page (blank title) results in collapsed UI element in menu builder

Reported by: jafoca Owned by: SergeyBiryukov
Milestone: 3.7 Priority: normal
Severity: normal Version: 3.1
Component: Menus Keywords: has-patch commit
Focuses: Cc:
PR Number:

Description

This minor issue has to do with the custom menu interface and titleless pages pages - this is handled somewhat gracefully when you initially create a titleless page using (pending) placeholder text, so I thought I would report it.

Issue preconditions

  • WordPress 3.1
  • Page created with title and body text
  • Page added to a custom menu and saved

Steps to recreate

  • remove title from the page from one of the "edit page" UIs
  • visit the Menus interface
  • you should now see a collapsed menu item in the menu creation interface (screenshot attached

Tested In: Chrome OSX 10.0.648.127 | Firefox OSX 3.6.13

Attachments (4)

wp-menu-bug.jpg (57.0 KB) - added by jafoca 9 years ago.
screenshot showing collapsed menu item
16787.diff (329 bytes) - added by garyc40 9 years ago.
set min-height for menu item title
16787.2.diff (316 bytes) - added by MikeHansenMe 7 years ago.
refreshed
16787.3.diff (321 bytes) - added by vinod dalvi 6 years ago.
Refreshed

Download all attachments as: .zip

Change History (12)

@jafoca
9 years ago

screenshot showing collapsed menu item

#1 @nerx
9 years ago

  • Keywords needs-patch added
  • Severity changed from minor to normal

Test results: True. UI Collapse. (Only 3.1, doesn't happen in other versions!)

@garyc40
9 years ago

set min-height for menu item title

#2 @garyc40
9 years ago

  • Keywords has-patch added; needs-patch removed

A quick fix would be adding CSS min-height to the title (patch attached). Another direction would be outputting a default title such as (No title) to keep the title box occupied when there's nothing there.

#3 @hakre
9 years ago

to me it looks like as if the wrapping element is not taking care of such. Adding a default title would probably the most easy hotfix or just adding good old   to the output.

@MikeHansenMe
7 years ago

refreshed

#4 @MikeHansenMe
7 years ago

  • Cc mdhansen@… added

#6 @SergeyBiryukov
6 years ago

  • Keywords commit added; ui-feedback removed
  • Milestone changed from Awaiting Review to 3.7

Reproduced in 3.6. 16787.2.diff looks good.

@vinod dalvi
6 years ago

Refreshed

#7 @vinod dalvi
6 years ago

  • Cc mozillavvd@… added

#8 @SergeyBiryukov
6 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 25211:

Set min-height for menu item title. props garyc40. fixes #16787.

Note: See TracTickets for help on using tickets.