WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 12 months ago

Last modified 12 months ago

#16797 closed defect (bug) (duplicate)

Edit Tags admin + custom post type + custom taxonomy

Reported by: kanuck54 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Taxonomy Keywords:
Focuses: Cc:

Description

I've registered the custom post type fp_toy, and the custom taxonomy fp_milestone. Both have show_ui set to true. I have the fp_milestone taxonomy associated with both fp_toy and post.

If I click Toys > Milestones in the admin, the URL is edit-tags.php?taxonomy=fp_milestone&post_type=fp_toy; but in the navigation menu, it appears that I'm in Posts > Milestones. (This is minor, but may help with diagnosis.)

Worse, in the list of Milestones, I see an automatically populated column named "Toy," which would be correct if it were indicating the number of Toys per Milestone; but it is counting all posts associated with a Milestone, not just those with a post_type of fp_toy.

Worst of all, clicking this (incorrect) post count should take me to edit.php?fp_milestone=create&post_type=fp_toy; instead it's taking me to edit.php?fp_milestone=create&post_type=post. The result is that I have no way (without URL manipulation) to see all Toys for a given Milestone.

Change History (3)

comment:1 scribu3 years ago

The incorrect count has been mentioned before: #14076

comment:2 ericmann12 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Mentioned before in #14076, which was closed as a duplicate of #14084, which was closed as invalid. Closing as duplicate.

comment:3 helen12 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.