WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#16803 closed enhancement (invalid)

admin bar sub menus should open only after a user had clicked the menu

Reported by: mark-k Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: UI Keywords:
Focuses: Cc:

Description

With the admin bar active in the front, when moving the "mouse" from the location bar of the browser down to the content area, a menu might popup and hide the content/create a distraction.

IMHO menus should be triggered only when a user had clicked one of the high level menu buttons like it is being done in desktop applications menus.

Change History (5)

comment:1 @hakre4 years ago

Thanks for reporting the issue. Please keep in mind that this is subjective. As a hot-fix i can only suggest you to disable the admin bar completely as it behaves in the way to open submenus on mouse hovering instead of clicking.

But i think your point is valid as this is a admin bar and not a site-drop-down-navivation.

what is your level of experience with CSS, PHP and HTML?

comment:2 follow-ups: @nacin4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This is expected behavior. A plugin can override this behavior if it is so desired.

comment:3 in reply to: ↑ 2 @hakre4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to nacin:

A plugin can override this behavior if it is so desired.

Maybe you can share that information?

comment:4 @nacin4 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

You don't need to re-open tickets to ask questions.

Overriding the behavior would involve implementing your own JavaScript in lieu of the core JS.

comment:5 in reply to: ↑ 2 @mark-k4 years ago

Replying to nacin:

This is expected behavior. A plugin can override this behavior if it is so desired.

And that is the reason it is an enhancement request and not a bug report......

Try having a multisite install with many blogs managed by you and move your mouse over the menu. It is a big distraction because most of the time you don't do anything which involves the menu.

In my small multisite install the first question I had from users after upgrading to 3.1 is how to turn the admin bar off, and I think this behavior is a major reason for that request.

Note: See TracTickets for help on using tickets.