WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#16831 closed defect (bug) (duplicate)

Commenting images in the Page or Post text-editor will break the page

Reported by: jroakes Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Formatting Keywords: needs-patch close
Focuses: Cc:

Description

If you add <!-- --> around an image as in:

<!-- <a href="http://site.com/wp-content/uploads/2011/02/ico-mega-mail.png"><img src="http://site.com/wp-content/uploads/2011/02/ico-mega-mail.png" alt="" title="ico-mega-mail" width="40" height="35" class="alignnone size-full wp-image-73" /></a>-->

in the editor of the edit post/page screens using "html" mode the commenting is not handled correctly on the front-end. When the_content() is called the <!-- part is left in and the --> part is stripped effectively commenting all of you page from the <!-- to the next time you have commenting in your template file. I have tested in 3.0 and a new installation of 3.1.

Change History (3)

#1 @scribu
10 years ago

  • Component changed from Editor to Formatting
  • Keywords needs-patch added

Confirmed.

#2 @solarissmoke
10 years ago

  • Keywords close added

Isn't this a duplicate of #8912 ?

#3 @scribu
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Indeed.

Note: See TracTickets for help on using tickets.