WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16848 closed defect (bug) (duplicate)

/wp-admin/admin.php: Setting 'memory_limit' makes Admin inaccessible

Reported by: mastermind Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

After upgrading an older blog to 3.1, I could not enter the admin area of the site in question.

I was able to track it down to the following lines in /wp-admin/admin.php:

if ( current_user_can( 'manage_options' ) )
	@ini_set( 'memory_limit', apply_filters( 'admin_memory_limit', '256M' ) );

Commenting these lines makes WP's admin area accessible again.

Removing the @ before ini_set while having WP_DEBUG set to true doesn't throw any errors.

I have no special setup (can post vHost config, if necessary). My machine is a Ubuntu 10.04 LTS, with a distro-provided LAMP stack. The global php.ini is nothing special, either.

I have disabled all plugins, just to see. But to no avail.

For now, I can only keep these lines deactivated.

Change History (5)

comment:1 ocean903 years ago

  • Keywords reporter-feedback close added

Can you take a look at your apache error log, seems to be a duplicate of #13847.

comment:2 follow-up: mastermind3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

True, this is a duplicate. Disabling Suhosin fixes it.

Sorry, I overlooked the respective bug when searching for 'memory_limit'.

However, I will not disable Suhosin, I'd rather live with a patched WordPress.

Last edited 3 years ago by mastermind (previous) (diff)

comment:3 duck_3 years ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted

comment:4 in reply to: ↑ 2 ; follow-up: hakre3 years ago

Replying to mastermind:

However, I will not disable Suhosin, I'd rather live with a patched WordPress.

Next to disabling suhosin or patching wordpress, you can configure suhosin as well: suhosin.memory_limit (More Info: Mysteries about the WordPress Memory Limit)

comment:5 in reply to: ↑ 4 mastermind3 years ago

Replying to hakre:

Next to disabling suhosin or patching wordpress, you can configure suhosin as well: suhosin.memory_limit

That helped, thanks!

Note: See TracTickets for help on using tickets.