WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 4 years ago

Last modified 14 months ago

#16868 closed enhancement (duplicate)

Add WordPress Required Version and Tested Up To Version for themes

Reported by: cais Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Themes Keywords: has-patch
Focuses: Cc:

Description

The premise of this idea is for Theme authors to be able to add a reference to the version of WordPress their Theme requires to work correctly; and, the version of WordPress the Theme has been tested up to. This idea comes from the the plugin readme.txt file and some of the data that is expected to be found there.

Once implemented, further enhancements to the Appearance tab in the Administration Panels can be added to better inform end-users on the compatibility of the Theme with their current WordPress installation.

Attachments (2)

theme_add_version.php.diff (3.4 KB) - added by cais 7 years ago.
/wp-content/theme.php diff
Updated_Version_of_WordPress.patch (3.2 KB) - added by cais 5 years ago.
Update to original patch; name changed to keep original patch for reference

Download all attachments as: .zip

Change History (16)

#1 follow-up: @ocean90
7 years ago

  • Summary changed from Add WordPress Required Version and Tested Up To Version to Add WordPress Required Version and Tested Up To Version for themes

cais, we use tabs instead of whitespaces for indentation, can you update your patch please?

#2 @ocean90
7 years ago

Related/Duplicate: #13780

@cais
7 years ago

/wp-content/theme.php diff

#3 in reply to: ↑ 1 ; follow-up: @cais
7 years ago

Replying to ocean90:

cais, we use tabs instead of whitespaces for indentation, can you update your patch please?

Updated ... not sure what happened with the first version. Sorry for the inconvenience.

#4 in reply to: ↑ 3 @jane
6 years ago

Replying to cais:

Updated ... not sure what happened with the first version. Sorry for the inconvenience.

There's a checkbox to overwrite files of the same name, you probably just didn't rename the file?

#5 @SergeyBiryukov
6 years ago

  • Milestone changed from Awaiting Review to WordPress.org

#6 @SergeyBiryukov
6 years ago

Closed #17098 as a duplicate.

#8 @ramiy
5 years ago

  • Cc r_a_m_i@… added

#9 @sabreuse
5 years ago

  • Cc sabreuse@… added

#10 @mercime
5 years ago

  • Cc mercijavier@… added

#11 @cais
5 years ago

Updated the patch ... needs testing, but should accomplish the same goals as the original patch did when it was submitted.

@cais
5 years ago

Update to original patch; name changed to keep original patch for reference

#12 @sabreuse
5 years ago

Tested the new patch with trunk; everything works as I'd expect and I'm able to get/display the new headers.

Supported/required versions would be a major help to WPTRT: even with just what we see here, having an officially-supported way for authors to specify the information would be terrific, but more importantly, it gives us the ability to add functionality to theme-check, work towards getting automatic checks into future versions of the installer, etc.

#13 @SergeyBiryukov
4 years ago

  • Milestone WordPress.org deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13780.

#14 @swissspidy
14 months ago

#37704 was marked as a duplicate.

Note: See TracTickets for help on using tickets.