Make WordPress Core

Opened 13 years ago

Closed 13 years ago

#16874 closed defect (bug) (worksforme)

Admin bar problems in IE7 and Chrome

Reported by: wpdavis's profile wpdavis Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: UI Keywords:
Focuses: Cc:

Description

Love the new admin bar, but I'm noticing a minor problem in Chrome and a slightly larger problem in IE7. I looked for a ticket already reporting the problem and couldn't find one — if I missed something I apologize.

In Chrome, the admin bar goes behind any flash, such as videos and some ads (see attached screenshot). For the record, this doesn't seem to happen with wp.com's admin bar.

In IE7, the submenus appear way to the right on hover, so there's no way to get to them (also attached screenshot).

Attachments (4)

admin-bar-ie7.png (199.8 KB) - added by wpdavis 13 years ago.
admin-bar-ie7.2.png (199.8 KB) - added by wpdavis 13 years ago.
admin-bar-chrome.png (182.7 KB) - added by wpdavis 13 years ago.
admin bar ie7 no plugins twentyten.PNG (48.7 KB) - added by wpdavis 13 years ago.

Download all attachments as: .zip

Change History (13)

#1 @solarissmoke
13 years ago

  • Keywords close added

Both these issues look like a problem with the CSS for your theme (which is probably why it works on wp.com). I'm unable to reproduce with WP3.1/twentyten.

#2 follow-up: @nacin
13 years ago

I'd be surprised if we missed the IE7 bug.

The flash issue is another story. We take oEmbed HTML at face value, which means they're typically missing wmode=transparent. That causes this. Very little we can do there.

#3 follow-up: @wpdavis
13 years ago

Thanks Nacin, defining wmode fixed the Chrome problem.

However, the IE7 bug is a different story. I should have been clearer — it occurs for me whether I'm using a clean install and also on wp.com. I can send you a new screenshot tomorrow, if you'd like.

#4 @wpdavis
13 years ago

FYI, attaching a screenshot on IE7 no plugins default theme.

#5 @solarissmoke
13 years ago

That's odd. I still can't reproduce - it works fine in IE7 as well as IE8 in IE7 mode. Hopefully someone else can... I would be very surprised if it's OS-dependent, but that's all I can think of.

#6 in reply to: ↑ 3 @dd32
13 years ago

Replying to wpdavis:

However, the IE7 bug is a different story. I should have been clearer — it occurs for me whether I'm using a clean install and also on wp.com. I can send you a new screenshot tomorrow, if you'd like.

Do you have access to another PC with IE7? Just to verify it is IE7 in general and not a addon? (As unlikely as that may be, but since we cant duplicate it)

#7 @solarissmoke
13 years ago

  • Keywords reporter-feedback added; close removed

#8 in reply to: ↑ 2 @SergeyBiryukov
13 years ago

Replying to nacin:

The flash issue is another story. We take oEmbed HTML at face value, which means they're typically missing wmode=transparent. That causes this. Very little we can do there.

Actually, we can: #11436

#9 @ocean90
13 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Can't see a problem in IE7 with the Admin Bar.

Please reopen if the issue still exists, but check if all your plugins are deactivated and you are using the default theme.

Flash issue can be discussed in #11436.

Note: See TracTickets for help on using tickets.