WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 8 months ago

#16880 closed enhancement (invalid)

Suggestion: login links on all pages

Reported by: dougal Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords:
Focuses: Cc:

Description

My wife is (finally) getting to work with WordPress at her job. As a relative newcomer to *really* digging into WP, she's hitting on a couple of things that I tend to just gloss over and ignore. One of them was this:

She wanted to log in to wordpress.org, but had forgotten her password. She did a password reset, and of course, afterward, she wanted to go back and manually reset her password to something she'd remember. So she went to the main wordpress.org homepage, only to find that there's no login link or any other indication of where one might go to change your password.

Of course, *we* know that you can get those links from the Support forum or the Extend area, but for her, it was not immediately obvious.

I just thought I'd suggest that the login block should appear on all pages of the site, not just on a few select ones.

Change History (6)

comment:1 Otto423 years ago

Yeah, I was planning on adding something to Profiles to make this more obvious, and redirecting all the various profile pages to there.

comment:2 dd323 years ago

  • Milestone changed from Awaiting Review to WordPress.org

comment:3 dougal3 years ago

Actually, after talking to Susan in more detail about it last night, the main confusion didn't arise from the login links not appearing on the home page, it was because she had originally logged in from the extend/plugins page, and the profile link there acts differently from the profile link in the forums.

But the basic gist of the problem is still pretty much the same: the links should be consistent throughout the site, and it should be fairly obvious how to reach the page where you can edit your profile information.

I can understand why it behaves differently in different areas (e.g., the Forums run bbPress, Codex is MediaWiki), but I can also see how it could be confusing to somebody who is new to the wp.org site. Here's a rundown:

  • Home page: no login link/info
  • Showcase: no login link/info
  • Extend: no login link/info
    • Extend/Plugins: login link; name leads to plugin contributions info; no link to edit profile
    • Extend/Themes: login link; name leads to theme contributions info; no link to edit profile
    • Extend/Mobile: no login link/info
    • Extend/Ideas: login link; name leads to Ideas topics/replies list; link available to edit profile
    • Extend/Kvetch: no login link/info
  • About: no login link/info
  • Docs: Codex; MediaWiki; Has its own login/profile setup.
  • News: WP blog; I don't know if everybody can login there, or if I still have a Subscriber-level login due to my "developer emeritus" status.
  • Forums: login link; 'View your profile' link leads to profile, with Edit link, and summary of forums activity
  • Hosting: no login link/info
  • Download: no login link/info

It might not be easy to make everything completely consistent. But every page should at least have a block with either a link to login, or if you're already authenticated, a link to a profile page where your main info and password change functionality resides.

comment:4 Genesis20013 years ago

  • Cc zack@… added

comment:5 devinreams9 months ago

This appears to be an old or esoteric item to address. Given that tickets for wordpress.org have moved to http://meta.trac.wordpress.org perhaps it makes sense to close this and re-open or contribute to a new or existing tickets over there?

Related #34 and #35

comment:6 samuelsidler8 months ago

  • Milestone WordPress.org deleted
  • Resolution set to invalid
  • Status changed from new to closed

If there are specific places we should add a login link, those can be filed on the meta trac. This ticket is no longer valid these days.

Note: See TracTickets for help on using tickets.